PDA

View Full Version : IS 7.04 Crashes on start



ebaichtal
07-25-2002, 05:08 PM
Just d/led SP4, saved it to my computer and then ran it later. IS 7 no crashes on start.

I've uninstalled and reinstalled twice more and get the same crash after I install SP4.

I'm running WinXP Pro on a laptop, and install 7.02 from CD first. Then I run SP4 and when it reboots and I try to start it I first get the "Windows Installer" dialog saying "Preparing to install..."

Then I get an error right after "Unhandled Exception Error Number 0x80040706 Description: Object reference not set Setup will now terminate"

I've wasted two days now removing IS and then reinstalling and then waiting for SP4 to finish. How can I fix this?

I am trying to switch from 6.31 to 7 because 6.31 causes a uninstall bug when the Maintenance Wizard updates stuff (I posted this error on the 6.x group -- and no answers) so I REALLY NEED TO GET A WORKING INSTALLER WORKING so I can do product updates, etc.

Is this a known bug? Is there something I can set in the isdev.ini file? What can I do to fix this? Please let me know ASAP.

-Ed

LewisQ
07-25-2002, 05:17 PM
I would email IS Tech Support and ask for a link to the full version of 7.04. Just a hunch...

bignikku
07-25-2002, 06:06 PM
had the same issue...so I installed uninstalled 7.04 and reinstalled but this I used the full installer.

doesn't crash as much now. only when I am in the middle of making a ton of changes!!!!!

ebaichtal
07-26-2002, 02:24 AM
k, I'll ask for the full version link and see what I get. :)

In the meantime my boss wants me to go ahead with 7.02, from what it reads like in this forum 7.04 is fairly buggy anyway. So maybe I should just stick with 7.02 for now...?

Carsten Segieth
07-26-2002, 05:31 AM
please try to REPAIR the Dev7.04 installation from the ARP menu - and don't worry, that it shows "... successfully uninstalled ...". For me it worked after a REPAIR.

Wystan
07-26-2002, 07:55 AM
LOL- Kind of Ironic no?- Install Shield's installations always seem to have problems. You would think they of all people could put together a working install package!

I ran into the same error on 7.04- and I had bad errors when I upgraded from 7.02 to 7.03.

Regarding the comment that 7.04 being buggy- I have not had a chance to test it yet as I am attempting to fix the upgrade as I type- BUT- I'm afraid you will find the version 7 in general has a lot more bugs than what they had with version 6.

Version 7- does have a much better layout though- and is overall a better product- it'll be excellent when they get it working properly.

As a general warning to everyone though- wait till you have some slack time before upgrading- from my limited experience upgrading versions almost never goes smoothly.

Carsten Segieth
07-26-2002, 08:09 AM
running as long as possible with 7.02 is a good idea, if there are no problems in the 7.02 that stops you. We didn't use 7.03 (for the reasons described above ... :-), but now we had to change because we need the fix for minor upgrades ("there is already installed a version of the same product on this machine...").

GCharos
07-29-2002, 04:00 AM
A repair seems to have fixed it for me also. Looks like the way to go