PDA

View Full Version : PublishFeatures Garbage in Log



Mike.Weeks
07-25-2002, 08:29 AM
Has anyone seen this? The garbage characters are supposed to be a Component GUID. This particular attempt failed. It hung with four instances of msiexec running on a win2000 box. IDriver also sticks around.

One instance of msiexec was consuming 100% CPU. When canceled, the normal dialog came up. Hit ok and nothing, just hang.

If you kill the instance of msiexec thats eating cycles, the rollback begins and completes.

This is repeatable in 7.04


Action 8:56:33: PublishFeatures. Publishing product features
MSI (s) (A8:BC): Executing op: FeaturePublish(Feature=Help,,Absent=2,Component=_XoVzp=0g?6y_=@F?}lCrj^N?,6Rg@@.mSR(*0]_RA`,hG!+f89cSqEYJ+cQ3g'zv2YDz=`Wo3yS@pxkI]YHm=7fZ8Vgs{+%n*J9re,w5p&mT?g?[my5iIR1`n`-yMACE@+.!]Y0elbAHhZm9E%cL@`qiC=K,)c`l8XUA!]AR=.]InKU
Rw%%-j[3(2_0U@uH6NJo&&o'R4_~8@A0_89Fl1@O%zYN~'9,G.Td*=)%4-Ky7q34j=cAzf-Xh@R(ZMDhQL$DP`l]@%oIU?]]*ag-gzRe7RILtCB00?_?dw6bCN]Lto@9,xxRS??&fha'oCzhk-6-yIh?$@eTYL.1_o,4N}H*t81[S956Lt`N)]b`J&rqs=H[c@owZX*EcM36GE)1OrLo6=&rk7Kl?E_*7Dr5bPKd7@O$Xw=e5FY-*pY'Ngqg'=s
`yu!R_0fjAJDCBbpw@?wm*MYpNd8`dQB)4nH4V?.oTb$Fj!Kc0a(`5xtB.=}zv$NOT%ljdZgq91mX-@fzv,4w%cp!lcRK!0.Rp?IHOli(D!wODi'WlU2bo@k5wVPf&Qdf@tbn99f{F?gzH0v0oRXrn*{[vbQeu=wG%.r99_M)m7XvY!x_m9Y-h$U]{Ez+_iHkqiyBH=qWQpBJh()_RjX[VaycD?E~bBYF*@x4A)!.NVNkl=3bx9${_Y5NIpcVTn
skq8x3??zTn3!{6[w,!RnV==~~8OjiUqdf0C{xIpfL!9}91*1n,!np)n(mH?*O_@D9KEwJ_jyG6Owjcg~)l8WW62djdx1!1Dksw+i&e=}9gu78q3t$H74s4r2Y(@U4F=&Fhp0%q}kxVa[L[=+9-zb&mf1KguAhhVJN?@hxPHWx{['_pgH{6}eR_9DF^`VW`z(-eI4bbconj?2W_7imVAi1CjB1nFVGx?~v+xa*FMM6]I~`DrN5V@Bw!p!1uShdo
-vNx!mEQ@[fjM3Ccu^(hg

Keppler
07-25-2002, 08:39 AM
That's not garbage.. looks like encrypted identifiers to me

if you look in the registry under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\[SID]\Products\[GUID]\Features
you'll see examples...

Mike.Weeks
07-25-2002, 10:08 AM
You are right. I must have been sleeping through that part of Microsoft Registry School.

I'm still looking for THE cause of this failure in the log.

Mike.Weeks
07-25-2002, 10:22 AM
This is the error when trying to cancel:


-------------------------------------------------

Believed Error Found:
Action 9:03:15: SetupInterrupted. Dialog created
Action start 9:03:18: ISCleanUpUserTerminate.
Action ended 9:03:18: ISCleanUpUserTerminate. Return value 3.
DEBUG: Error 2896: Executing action ISCleanUpUserTerminate failed.
Internal Error 2896. ISCleanUpUserTerminate
Action ended 9:03:18: SetupInterrupted. Return value 3.

Mike.Weeks
07-25-2002, 11:42 AM
This is the error when trying to cancel:


-------------------------------------------------

Believed Error Found:
Action 9:03:15: SetupInterrupted. Dialog created
Action start 9:03:18: ISCleanUpUserTerminate.
Action ended 9:03:18: ISCleanUpUserTerminate. Return value 3.
DEBUG: Error 2896: Executing action ISCleanUpUserTerminate failed.
Internal Error 2896. ISCleanUpUserTerminate
Action ended 9:03:18: SetupInterrupted. Return value 3.

yiannis
07-08-2003, 02:02 PM
That is the first time that I am seeing rubish in the FeaturePublish action.

I have created far too much setup apps and I haven't seen them before. I don;t think that this is a part of Microsoft problem but InstallShield's problem.

For example.

I have created a setup in the past that is working fine. Same thing now is not working after a new compile. Is this Microsoft's problem?

Any way can you tell me where the error is or where to find it ?