PDA

View Full Version : Upgrade does not work with migrated 7.0 Project to 7.04 IS Dev.



Saugata Guha
07-24-2002, 05:12 PM
The Minor upgrade I tired with a new Project built
by 7.04 works fine. (with just 2 files)

The same process when followed on my real project
which was first created with IS Developer 7.0 and
migrated to 7.04 did not work completely.

What did not work:
-----------------------
-No Changed files were upgraded.

What worked:
-----------------
When setup.exe is run again it hits the
OnResumeUIAfter()/...Before().

What I did:
--------------
1) Changed the Package code for each build
2) Changed build number(bbbb) in the Version, jj.ii.bbbb
Changed ii also did not make any difference.
3) Applied the first time no upgrade fix. Added the Custom action.
4) In the OnResumeUIBefore() I have put some code
which saves some of the users configuration files,
which needed to be migrated. in the SUPPORTDIR
Call FeatureReinstall(), does not make any difference.
5) In OnResumeUIAfter()
Thought file transfer upgrade by installShield will be done
before it hits this, but it did not.
So I moved the restore config file code to
OnEnd(). Still the same.

How do I debug my project, instead of creaing it
from scratch using 7.04.

Thanks
sguha@jareva.com

Saugata Guha
08-05-2002, 07:37 PM
I am still working on minor upgrade,
This is really bad.
I had to buy silver support, talked to the engineers, but
most of these guys are pretty worthless.

They could not find any problems from my logs,
asked me to remove my setup.rul files, and just add files,
with out my setup.rul and see if that works.
Did not work. Any way I just wanted every one to know
that InstallShield should do some thing about this
upgrade nigtmare. I would just drop this product
because of that.

One thing I found out that
setup.exe /v"/l*v c:\winnt\my.log" will kill your upgrade, for
what ever reason it did not even hit my OnResumeUIBefore
handler.

Use
setup.exe /Verbose"c:\winnt\my.log"
instead.

It does not hit my OnResumeUIBefore() handler.
-Saugata.
sguha@jareva.com