PDA

View Full Version : LaunchAppAndWait fails to run J++ .exe



erick00
07-24-2002, 02:52 PM
Has anyone tried to use the InstallShield LaunchAppAndWait function to run a J++ generated .exe? When I try this using IS 7 (SP 4) on Windows XP Pro I get an error window pop up which says "Not enough storage". I get this same error when I attempt to run "wjview.exe" with no arguments. No such error occurs when running a helloworld C++ .exe.

I have attached a helloworld.zip file which contains the J++ helloworld.exe.

Any feedback would be greatly appreciated!

LewisQ
07-24-2002, 02:58 PM
Did you get the error when running the setup from the run box?

erick00
07-24-2002, 07:01 PM
Yes, the error "Not enough storage is available to complete this operation" occurs when I run setup.exe from the start->run box.

LewisQ
07-25-2002, 08:36 AM
Then it is not a LaunchAppAndWait() issue.

erick00
07-25-2002, 09:00 AM
Oops, sorry, I meant to say that the LaunchAppAndWait DOES FAIL when run from the run box. It IS an InstallShield issue.

LewisQ
07-25-2002, 09:27 AM
Try do do a ChangeDirectory() to where the J++ exe is before launching with LaunchAppAndWait()...

I had a report of an error similar to yours a couipoel weeks ago and we never managed to reproduce it so I am really curious...

erick00
07-25-2002, 10:40 AM
Sorry, I just tried using ChangeDirectory and it still fails!

Can you please try to reproduce this problem on IS 704? In my previous email, I attached a hellworld.exe which is a Visual J++ 6.0 generated executable. It should be easy to try. Do it on Windows XP Professional. Thanks, I have spent too much time on this already!

erick00
07-25-2002, 10:41 AM
If you try to reproduce it, put the helloworld.exe in DISK1.

LewisQ
07-25-2002, 11:04 AM
I can't for two reasons:

- We will not move anything into 7.04 for 2 more weeks and I don't have right now a spare machine to install 7.04
- Security policy does not allow me to download and run apps off the web

I will try to test this from home sometime this week but I can't promise when.

erick00
07-25-2002, 01:53 PM
Thans Luiz!

InstallShield should address bugs found by the user community and reported via email without having to pay $399 for a Bronze support contract, given the software is NOT cheap already.

erick00
07-26-2002, 08:13 AM
I finally figured out a workaround.

The LaunchAppAndWait function was called from a function which was triggered by an OnInstalled event. If I call LaunchAppAndWait during the user interface sequence then I have no problem running the J++ executable.

I still don't really know why the J++ executable failed.