PDA

View Full Version : Problems with proxy and running agent on startup



neildavidson
07-15-2002, 03:13 AM
When AgentClass.AppUpdate with the RunType.AppStart parameter and the user is accessing the web via a proxy server then a messagebox pops up asking for a user name and password for the proxy server. People find this quite annoying.

Although I can see this is necessary if checking for updates manually, or after an install, where the end user has actually chosen to do an update, it might be more appropriate not to search for updates if a username / password are going to be required for a proxy server when the update check is meant to be happening silently.

- Neil

Chris Woerner
07-15-2002, 08:20 AM
In general, I completely agree with you. We want an application start-up to be completely silent unless an update is available. We are looking at ways to implement this.

Just to get a little more information on your specific case........Is this customer required to login each time to use the internet? Or, is the login only required once per day? Does this customer store user/id password in the browser settings?

Chris Woerner

neildavidson
07-15-2002, 08:58 AM
Chris,

Thanks for investigating. One customer who is having this problem says:

"
We login each time that we access the internet. User ID / Password are entered each time. There is a timeout period after which the user ID / password must be re-entered. I'm not sure what that period is but it doesn't occur during a normal browsing "session".
"

syalamarti
08-21-2003, 10:41 AM
Hi,

We have similar issues with update over a proxy server.

Currently, the Update Service Agent uses the IE settings when going thru' a proxy.

It would be great if we can specify the proxy information (server addr, userid/pwd etc.) via the Update Service SDK.

Regards
Srini Yalamarti