PDA

View Full Version : Timeout on displayreport.asp



neildavidson
06-08-2002, 02:55 AM
Whenever I try to view reports on services.installshield.com I get SQL timeout errors. This happens when I refresh the company stats too.

Chris Woerner
06-10-2002, 09:17 AM
I confirm that this can be problem. I have seen the timeout when I run reports against a large data set (more than one month of data). We are working to optimize the queries to avoid the timeout.

Chris Woerner
06-13-2002, 07:13 PM
We have optimized the report queries. You should not see the timeouts anymore. We are still working on the company stats.

neildavidson
06-27-2002, 04:23 AM
I'm still getting timeouts on the reports and company stats page. They went away for a bit, but they're back now.

Chris Woerner
06-27-2002, 09:23 AM
We haven't released the fix for the company stats, so that doesn't surprise me. However, the reports should be fine. I am continually running reports against InstallShield data, and I have not seen a timeout since we improved the SQL.

Please tell the name of the report and the date range you are using. We will need to see the problem, so we can debug.

Thanks for your help. Sorry for the problem.

neildavidson
06-27-2002, 10:12 AM
Chris,

It seems to be working now. Strange.

Chris Woerner
06-27-2002, 10:14 AM
After your post, I went and ran 20 reports. I did see the timeout on two cases. We will do some more digging today. Thanks.

neildavidson
06-27-2002, 10:25 AM
Sounds like you might need a load testing tool. If you do, let me know, as I can provide one ;)

neildavidson
07-15-2002, 03:09 AM
And do you know when a new SDK will be available ?

neildavidson
07-16-2002, 02:37 AM
It's been impossible to run any reports for over 6 weeks now due to the timeout issue.

Can you please let me know when this is going to be fixed.

Thanks,

- Neil