PDA

View Full Version : Jet40.msm don't run



viviana
05-29-2002, 01:32 AM
I downloaded the new jet40 merge module from the web page, and changed my project to include it. The installed version of my software does not run correctly unless MDAC_typ is run manually. I verified and my project included DCOM95 and MDAC 2.6.
Before, I run mdac_typ.exe as custom action, but i can't include an option for ask to the user if must be install it. The options are:
1) run correctly the merge module
2) ask the user if install the mdac_typ.exe
Can I make this?
Sorry for my bad English. I speak Spanish.
Thanks.

johnhind
05-29-2002, 09:45 AM
If you need Jet for Access databases, then it would be easier to use mdac2.5 which includes Jet, rather than mdac2.6 which does not.

If we beat you in the World Cup, I will help you more !!!


John:p

viviana
05-29-2002, 06:41 PM
Thans for the answer. But I need mdac 2.6, because with mdac 2.5 my software don't run correctly.

Sorry, but:
The next world champion will be Argentina !!!

johnhind
06-17-2002, 08:28 AM
Ok, now, can I help you !!!

John

viviana
06-17-2002, 04:36 PM
And your help?

johnhind
06-18-2002, 09:29 AM
I would suggest upgrading to 3.54 and using the latest merge modules. I think these have changed a lot.

What problems do you get when you use mdac 2.5 ?

regards
John

viviana
06-18-2002, 03:29 PM
I use Windows 2000 in my developer computer, so I need mdac 2.6. and the upgrade to 3.54 is very expensive, (dollar is very expensive in Argentina now)
Thanks,
Viviana

johnhind
06-20-2002, 03:13 AM
You can load mdac2.5 on your development computer and use it in your VB project. Versions 2.5 and 2.6 can exist together. It is worth a try as it simplifies your setup.

regards
John

viviana
06-20-2002, 12:23 PM
I don't want use mdac 2.5. I want run correctly InstallShield.
I paid for a program to install my aplicattions and I want that it run right.
Sorry for may bad English.
Thanks,
Viviana

johnhind
06-20-2002, 02:35 PM
Your English is better than my Spanish !

It might be worth re-creating your setup project, as Express gets itself into a mess.

Select mdac 2.6 and then Jet 4. Make sure you are not including any mdac files, such as msado15.dll or msadox.dll. These DLLs are sometimes picked up by mistake by the VB project scanner.

What files are you including in the setup ?

Chandima has done a lot of work with the mdac merge modules. You might want to just accept that mdac2.5 is the best way to go. Many people use it instead of mdac 2.6.

Buonas noches mi amigo,

John

viviana
06-20-2002, 05:49 PM
The setup was included both dlls: msado15.dll or msadox.dll, but it are version: 2.60.6526.0.
I will test the setup without it in a few days, because I must format a new disk for do it.
I'll tell you the results.
Regards, (o "Muchas Gracias")
Viviana