View Full Version : Agent does not do anything??

05-21-2002, 09:42 AM
Hello all,
I am trying to test the update service and figure out if we can use it with our application. So, I've registered my product on the web site, put the code into the install script and now I am trying to check for updates:

C:\Program Files\Common Files\InstallShield\UpdateService>agent -au{XXX-XXX-XXX} -AppStart

And then nothing happens. I understand at this point it should check for updates (display some message???) and start the application. What do I do wrong?

Chris Woerner
05-21-2002, 10:00 AM
When you call Agent.exe, you can call it from a couple of places.

Menu option (AppMenu): This will always show a UI. If there are no updates, Agent.exe will display a "no updates available" message. In this case, the user choose to look for updates, Agent.exe must show a UI even if there are no messages available.

Application start-up (AppStart): This will perform a check for updates every 'n' days. The interval 'n' was specified in the installation script. If there are no updates available, Agent will end silently. Why no UI in this case? When a user is starting your application, you only want to bother the user if there is an update available.

There are full flow charts in the online help that describe this behavior. Do an index search on "AppUpdate" to see the flow charts.

If you want to try a quick test, run this from the commandline on a machine with your application installed. Of course, your application must have been installed using an installation that includes the Update Service runtime. You should see a message that says "no updates are available".

"C:\Program Files\Common Files\InstallShield\UpdateService\agent.exe" -au{XXX-XXX-XXX} -AppMenu

Also, the Agent doesn't open your application. Your application calls the Agent. You need to add that commandline call into your application's code.

05-21-2002, 03:18 PM

Thanks for your reply. I called agent with -AppMenu option and it worked. However, when I installed my application on a different computer, agent -au{XXX-XXX-XXX} -AppMenu does not produce any output. I added UpdateService object into my project, and I verified that agent is indeed installed into Program Files\Common Files\InstallShield\UpdateService. If I run it from the command line, it still does not produce any output. Any troubleshooting steps you can recommend?