PDA

View Full Version : <Path> token not being recognized/used



Jwills
05-16-2002, 11:39 AM
Using 6.7 I've created a 'launch Associated Application' action on a left mouse button up event of a bitmap button object. I have the following file value set.

<Path>video\VfdemoAudio1v2.avi<Path>

Video is a directory one level below the directory where I am starting demo32 for testing.

When testing nothing happens. After replacing the <Path> token with a non-relative path (D:\program\video\vfdemoAudio1v2.avi) it works fine.

I can also create a new demo with a bitmap button and succesfully use the <Path> token to the same directory and file. I tried importing the scene to this new demo project and the old behavior (not working) resulted.

I've also tried to use the token and action on other objects in the same project with no success.

This all leads me to believe its a token recognition/use problem that is embedded in the project file itself. Any and all help would be greatly appreciated.

KimberlyH
05-16-2002, 12:14 PM
To help me understand this issue further I will need some additional information.

How are you launching the demo file to test run the launch action (ie: double-clicking the .dbd file, double-clicking the demo32.exe, etc...)?

Is the video file imported as a resource in the Resource Manager? If so, is it embedded or Imported by Reference?

From the information provided, your directory structure looks like this:

demo.dbd
demo32.exe
Video folder
- VfdemoAudio1v2.avi

Is this correct?

Do you have any other actions assigned to the Bitmap Button?

Are they any other Objects on top of or under the Bitmap Button?

Would it be possible for you to send a sample of the demo and video so I can see how the demo is set up and test the demo further?

I look forward to hearing from you.

Jwills
05-16-2002, 12:26 PM
I am double clicking demo32.exe.

The avi file is not imported into the project (resource manager) at all including by reference. Although I tried by reference during troubleshooting and had the same behavior.

The directory structure you have is correct.

The mouse button up event on the object has one additional action which is to play a sound (click) and it is before the action to launch the associated app.

There are no other objects on top of the bitmap button object and I have made sure that the 'demo always on top' option is not checked in the Demo Options.

I would be happy to send the project and file although the avi is around 20mb zipped. How would you like me to send it? Email? Can I get you email address?

Thanks

KimberlyH
05-16-2002, 12:40 PM
I would be happy to take a look at the demo file. 20 megs is too large to send through email. However, you can upload it to our ftp server at:

ftp://ftp.installshield.com/incoming

Username: anonymous
Password: your email address

Once the file has been uploaded, please post a message to this community letting me know it is available and the filename.

I look forward to hearing from you.

Jwills
05-16-2002, 02:56 PM
I have uploaded the files. They are named:

demo1.zip - this contains the avi file that lives in the video sudirectory
gskcd.dbd
gskcd.dsj

For testing I copy the gskcd.dbd file into my directory that has demo32.exe in it and then rename it demo.

Thanks for taking a look.

- John

KimberlyH
05-20-2002, 10:17 AM
Thank you for uploading the files. I am looking into this issue and will provide more information as it becomes available.

All the best,

KimberlyH
05-20-2002, 12:06 PM
After a lot of trial and error working with your demo I have found that it is a Text Object in the scene that is preventing the Launch Associated Application action from launching.

In the scene Solution - Demo I tried removing various objects to see if they were causing a conflict with the action. When I removed the Text Object labeled - Path, I was then able to get the action to trigger properly.

I am looking into this further to see if I can find why this Object may be causing a conflict. In the meantime, try removing this object to see if this corrects the issue for you.

I will post more information as it becomes available.

All the best,

KimberlyH
05-20-2002, 12:11 PM
I think I have found what is causing the conflict between the Launch Associated Application action and the Text Object. It appears that since the Text Object is labeled Path (the same as the DemoShield Tokens that are being used in the launch action), that it is causing a conflict when DemoShield is trying to process the launch action.

If you simply rename the Text Object to something else, the launch action should work fine.

I hope this helps.

Jwills
05-20-2002, 04:37 PM
Kim -

You where right. Thanks a lot!

I guess because PATH is a token its also like a reserved word which can not be used as the name of any other object in the scene.

That would be a nice one for the user guide so its not an undocumented 'feature'. :)

- John