PDA

View Full Version : Repackager won't run on NT4 Enterprise Server



Sonic Scripter
05-02-2002, 11:21 AM
Appologies if this has been covered before. I have tried using the search for this subject with no luck.

Basically I was wondering if anyone has had problems running the repackager on NT4 Enterprise Server.

When I launch the program from a network share and monitor the t-list, the "isrepackager.ex" appears for 10 seconds or so and thn vanishes. :( The program never launches. :confused:

I have also tried installing Repackager to the server and launching from there, but nothing appears to happen. :(

Any ideas ?

Thanks,
Sonic

Mike Snyders
05-03-2002, 11:44 AM
Sonic, what version of Internet Explorer do you have installed on that system?

Regards,
Mike

Sonic Scripter
05-07-2002, 05:10 AM
Mike,

All resolved now. Heard back from InstallShield support that this has been seen before:

The file SHLWAPI.DLL was missing from the Win\sys32 directory. (This is not installed by the OS or SP's). Will check where this should come from. Have taken from my Development PC for now.

I added this file to the source where I was launching Repackager from, and it loaded successfully. :)

Many thanks for your response anyway.

Cheers,

Sonic

Sonic Scripter
05-22-2002, 05:40 AM
Just thought I'd follow up on this for anyone else who runs into the problem.

The answer was that the file SHLWAPI.DLL is installed by IE4+. Hence on a bare NT4 Enterprise Server, I specifically did not want IE installed, so no dll file.

The chaps at Installshield said that this is a dependency that they will be eliminating in future as the problem has been seen a few times.

Quick and informative response from the Installshield Support team. Cheers guys. :)

Sonic.

jeronimo
05-23-2002, 05:05 AM
Hello,

isn't this problem resolved when you install the Service Pack 6a?

Regards,
Jerome