PDA

View Full Version : Am I stupid ?????????????



Emmanuel Zaspel
04-28-2002, 11:22 AM
Slowly I get pissed OFF !!!!

I Use AdminStudio 3.0 Professional, with the 3.01 Patch that not realy working till now ( see posts ) and the advertised Value Pack 1

If I run the ConflictSolver 3.2.0.10 to import an OSSnapshot 3.1.22.0 OS Image the Import Tab only show:

Import started at : 04/26/02 14:59:08 PM ...


The file '' was successfully imported into the ConflictSolver Database.

OS Snapshot import completed successfully.

BUT there is NOTHING added to the Database !!!
And the file has a name other then " !!!!

Till now I thing this Software is never realy tested throw an Realworld Workflow !!! from Building an "Clean OS" takeing an snapshot of this os installing an "old" application via the Repackager, modifing the output in Author, building an .msi File open it in Tuner modifying it and running the output against the ConflictSolver DB

I just spend 4 days till now to get this **** working but there bugs in Repackager, Author crashes if importing simple JDK 1.2.2, Conflictsolver do not import OSSnapshots. What comes next ?

Am I heck or what ?? Are there people out there using this stuff in a hole sucsessfuly ???

Regards

Pfeiffer
04-29-2002, 07:39 PM
I want to start by saying I am not making light of your posts.

DAMN... Does your machine even boot anymore??? What is your next post is going to end up reading "I clicked on the help button and now I can't get past the Blue Screen of Death". If you are the first guy to load the next patch, after you get everything finally working, someone may have to ban you from the posts :p
You are my ray of sunshine, I read your posts with my morning coffee and go "Now here is a fella with more issues with this software than me."
;) Little consolation I know...

I have got several of the same errors you have, the OS Snapshot one took me 14 hours to import. The ghost image took me 8 hours to build from scratch. I have got around most of them, and until you start importing ZenWork files, you don't know real stress...

Here is what I have got working, take it for what is worth.

1. Build yourself a 2000 Advanced Server [8gig / 30gig] partitions.
2. Install TS client AdminMode.
3. Throw an extra processor in it if you have one.
4. Install SQL Server, (don't get cheap and use an access database now).
5. Store your Source files and Builds on your second partition.

Your OS Snap go from 14 hours + to 30'ish minutes, and yes the data is there this time. BTW Conflict solver actually works with your new/legacy apps once you get them built. In my experiance with this tool so far, apps tend to import a little better from partitions, verses networked (Novell) drives.

Well sir that's my 2 cents, hope it helps.
Good Luck,
Keep up the posts "Its going to get worse, its the only thing you can really count on".

AllenSaxton
04-29-2002, 07:56 PM
No.

I have attempted to duplicate your problem as described without success. I have observed a similar problem but only in in-house code that we have under development.

In my case, I first installed AdminStudio v3.01 and generated a snapshot using this version of AdminStudio. I was then able to import this snapshot into AdminStudio. Later, I used the Update Service to download and install the AdminStudio 'Value Pack' and I was able to import the original snapshot, normally.

Can you offer any additional information about your system configuration? Specifically, can you confirm that the main AdminStudio About box identifies your software version as '3.01 Includes: Value Pack 1'?

Allen Saxton
InstallShield Development

Emmanuel Zaspel
04-29-2002, 11:04 PM
Greetings,

here it come:

- The basis is a 600Mhz MPS with 1GB RAM. ( will be a 1800 MHz with 2GB RAM soon :) Pfeiffer
- on this mashine I run 2 VMware Vms
- The Adminstudio Vm is with 384MB RAM
- Installed as follow: W2K Pro SP2 Slipstream, MDAC 2.7, WSH 5.6, Adminstudio 3.0 Pro retail from CD, the 3.01 Patch, the Value Pack ( if paches are the only hope... :) Pfeiffer ) thats all
- Yes Admin Studio identifys itself as 3.01 Value Pack 1
- The "Clean" with 256MB is: W2K Pro SP2 Slipstream thats all

The "Clean" is conected over Network with the Adminstudio one to run Repackager an OSSnapshot on a maped network drive.
The output is stored back on an other network drive on the AdminStudio maschine.
There on the AdminStudio mashine i work with the output.

The idea was to sepaerate everything ! to prevent trubble but it never worked.

Is it posible that my AdminStudio 3.0 orginal CD is a developer snapshot ? can u test thsi with a 3.0 + patch AND NOT like the others with a nice 3.01 one ??

Or better: WHERE CAN I GET THE 3.01 ?
Because i think with my 3.0 is something wrong, see the posted Tuner validation Output.

Regards

AllenSaxton
04-30-2002, 07:29 PM
Emmanuel,

Our QA people tried to duplicate the snapshot generation and importation process, using the AdminStudio distribution process that you have used (i.e. AdminStudio v3.0 CD install, AdminStudio v3.01 patch via the Update Service, and AdminStudio 'Value Pack' via the Update Service), without any failure.

The nature of your problem as reported is an immediate snapshot importation failure in which no error information is returned. Now, there should always be error information and it's absence puzzles me. I can offer two theories.

First theory is that the ConflictSolver database or database schema is corrupt. The 'Value Pack' will cause the ConflictSolver database schema to be modified. The failure of this schema update would cause problems for ConflictSolver. However, in the absence of any other importation problem, such as importing an MSI package, I would be forced to discount this theory.

Second theory is that the Snapshot build process did not complete properly. You system configuration as described is unfamiliar to me and this fact leads me to suspect that some aspect of the Snapshot build process failed. To try and confirm this theory, I would need some files from you. In your snapshot save directory, you should have an INI, NIR, and OSC file. Under ideal circumstances, if you could zip up these files and send them to me, then I would be most appreciative. However, I would settle for the just OSC file.

AdminStudio v3.01 when released was distributed as a full product on our production CDs. Due to size constraints and other issues, the preferred method for accessing any AdminStudio update is through the Update Service. The Update Service for AdminStudio will only distribute the software in MSI patch files. It may be possible to make the release available to you for download, but I don't believe that it will solve your problem.

Allen Saxton
InstallShield Development