PDA

View Full Version : unicode display issue



mrsharkbait
04-13-2002, 07:39 AM
I have a DemoShield application that displays the trademark symbol (TM) in unicode. In US XP and US Win2000 Pro
the display is fine, but on a Chinese XP Pro and also on Win98 the symbol does not display correctly.

Of course if I set the locale to US the display is OK, but I would like the Chinese XP users to be able to view my app properly using the native settings. Is it a problem with the font? I use the Arial font, which should be OK, unless the Chinese Arial is a little different.

Any suggestions as to why this happens is greatly appreciated.

KimberlyH
04-15-2002, 10:53 AM
Unfortunately, DemoShield does not support unicode text files for use during demo playback. Therefore, if you are using a text file saved in unicode format, DemoShield will not recognize this file during demo playback.

When localizing a demo for various languages, we suggest translating the languages on language specific operating systems. Then save the text file on this operating system to ensure the language characters are saved properly. When updating the text file with a different language, save as usual, not as unicode format.

When placing a copyright or trademark symbol within the text within your demo I would recommend using the Windows keyboard combination to ensure the character is not in unicode format.

For the trademark symbol you can use the following: Alt + 0153

I hope this helps.

ulidder
10-17-2007, 07:01 PM
Hi mrsharkbait,
Were you able to solve this issue? I am having the same problem in IS2008. The (R) symbol turns into ? in the Chinese string table. Any advise?
Thanks
Upkar.