PDA

View Full Version : internal build error -5062



luke_d
04-09-2002, 08:18 PM
Hi, my standard project produces this error message:

Building CAB files...
** Fatal Error: -5062: Internal build error

The documentation for this error number in the ISD7 help says to check the Installshield Knowledge Base, but the knowledge base says nothing about this error number.

My project was building fine yesterday.. nothing much should have changed besides the list of files included in the project. (I'm using automation to put files into components because it's too tedious to check so many files with the user interface).

Does anybody know what this error message means?

luke_d
04-09-2002, 08:41 PM
I have worked out the modification which causes this error. The field called "Previous Package" on the release page was previously blank, but then I added the .msi from a previous build (so that I could make a patch in the future). After this, this build failed.

Removing the "Previous Package" allows the build to proceed without error. This is not a solution (because I will need to use "Previous Package") but maybe it helps to narrow down the cause of the problem?

Art Middlekauff
04-23-2002, 06:19 PM
I am not sure what would cause this build error to occur. Could you please email me to work on possible ways to track down this problem. Thank you.

MarioC
11-20-2002, 08:48 AM
Did this problem have a solution?
I'm experiencing the same now and then. Emptying the previous package field solves this.

The only thing I did in the project was:
Rename a component (but keep its GUID)
Change the dynamic link for its files (all new files; so the filekey has changed too.)

The error occurs when it's building the cab file which contains the changed component.

Is the exact cause known of this error?

Mario

Art Middlekauff
11-20-2002, 12:32 PM
No, it is not clear to my why the 5062 would occur. Could you build from the command-line and use the -v option to generate a verbose build log. Then could you send me the log file (artm@installshield.com). Thanks.

Art Middlekauff
11-23-2002, 03:16 PM
Mario and I are working on this offline. This thread will be updated when the results are obtained.

AntonioDrusin
01-15-2003, 08:47 AM
I have the same problem. When I add the "Path Optimiziation" package I get the same error.
Any solutions yet?

Art Middlekauff
01-15-2003, 12:50 PM
Mario was no longer able to reproduce the problem. In order to diagnose and resolve this error, I would need to send you a custom version of our build that has extra diagnostics. Would you be willing to work with me on this? If so, please email me at artm@installshield.com.

AntonioDrusin
04-02-2003, 10:50 AM
Thank You, Art!

This was fixed in SP1 for InstallShield Developer 8.