PDA

View Full Version : Error on Building .NET installer, cannot resolve .Localized_Resource and other files.



jbridges
04-09-2002, 12:59 PM
:confused: I get an error when it is building, the error is as follows: "Error: -6221: Could not resolve Visual Studio .NET project output "SampleProject.Localized Resources" from component SampleProject.Localized_Resource"

Additionally it also misses the .Content_Files of one of the projects included as well. Now the project I am trying to build the installer for has other projects as part of it, could that be a problem?
I need all of the files that are part of this project. FYI, the project is a NET web project that works find through the Visual Studio IDE so it is not a problem with the .NET source code.

I used the VB.NET Project wizard to start this installer, this is the first time I have ever used InstallShield. Please help.

Art Middlekauff
04-23-2002, 02:09 PM
The "Localized Resources" output for a C# project will only be resolved if 1) the C# project actually contains localized DLLs and 2) the C# project has been built. Are you sure that your project has localized elements? Do other outputs resolve correctly from that project?

Also what is missed in the "Content Files"? Are all the files missed or just some?

jbridges
04-23-2002, 02:17 PM
The project is actually composed of two projects and one of the projects does contain DLL's. If I use microsoft's setup project then none of the content files or resource files are missed. It is a VB.NET project. I did fix one part of the problem, now the ContentFiles are included (it was showing in the project but was not included in the project), however the Loalized Resource files are still being included.

Chandima
04-24-2002, 04:16 PM
I am slightly confused. A few questions should clear things up a little:

1. Does your project have any Localized Resources?
2. Do you want to distribute these Localized Resources?
2. In the VB .NET wizard, did you associate the Loclaized Resources Output with a feature?

Please reply to chandimar@installshield.com. I don't visit this board too often so emailing me directly will be the quickest way to resolve this issue. Thanks!