View Full Version : Cannot apply newly created patch

04-09-2002, 09:49 AM
As a test, I created two IS7.02 standard projects, one for version 1 of a small set of two features and components, and one for version 2 of that same exact set of features and components. I followed the procedures in IS7 article Q105858 making sure to set the options correctly and specify the previous .msi package in the version 2 release build. Each version setup works fine. I install version1 on my system. Then I use the patch creation wizard to create a patch from version 1 to version 2 with the smart build option enabled and allowing it to decompress the two version setups into separate directories. According to the build log file for the patch all went well. However when I run the patch using update.exe, I get the error referred to in Q105858: "1: This installation can not be run by directly launching the MSI package; you must run setup.exe"

What the heck is going on?

04-09-2002, 09:52 AM
Just out of curiousity, if you follow the same procedures with a Basic MSI project rather than a Standard - does the same behavior occur?

There are currently known issues with Standard projects and patching/minor upgrades in InstallShield Developer 7.02. They are due to be fixed in Developer 7.03 which is due out later this month.



04-09-2002, 09:55 AM
I need the patching to work with Standard projects, I can't go back and modify what we've already shipped to customers! I need this patching stuff to work NOW with Standard projects. So, how can I get a fix as quickly as possible to this bug, then?

04-09-2002, 09:58 AM
I would recommend testing this in Developer 7.03 Beta. This can be downloaded from the link at the top of this community.

04-09-2002, 10:18 AM
In answer to your question, yes it does work for a basic MSI project. Guess that'll teach me to use InstallScript for installation projects that are of any importance.

04-09-2002, 02:55 PM
Since you've already released the installs, try doing admin installs for both versions then run the patch wizard using the admin installs. I haven't tried this personally but I saw it posted once.

If you still have the original projects and files you can create uncompressed releases and run the patch wizard on those as well. I can verify that this works.

04-09-2002, 03:02 PM
Thanks for the reply. Unfortunately, using admin uncompressed images does NOT work for me. I tried this. The problem appears to be a definite bug in 7.02. As suggested, I downloaded and installed the 7.03 beta - and suddenly no more problem.

09-12-2003, 01:38 PM
I am having the same "You must run setup.exe cannot call MSI directly" problem when running the Update.exe patch file.

Please help!!

09-14-2003, 03:38 PM
I ran into this problem last week and found the solution for my problem at: