PDA

View Full Version : error 1201 - Need 8000 KB disk space



adiesen
04-08-2002, 01:01 PM
I am testing out my InstallShield project on numerous machines and have run into an error on a Win2k sp2 machine. The error pops up at the beginning of the install:
error 1201: Setup needs 8000 KB free disk space in C:\

The C: drive has 74GB free.

Any ideas?

_doog_
04-08-2002, 01:27 PM
do you have write permissions on drive c:\
is there a tmp directory set?
do you have write permissions to the tmp-directory?

LewisQ
04-08-2002, 01:53 PM
If there are TMp, TEMP folders, clean them up. Usually helps. Defraging also comes to mind.

JeffCurless
04-10-2002, 04:13 PM
I have the same problem. I have an install that grew from 20meg, to 128meg. I have over 4 gig of disk space on drive c &d, nothing in any temp areas, defragged... and still have the issue.

OutOfDiskSpace Dialog reports:

C: size 12gb, available 3502mb, required 128mb, differences 3374mb

d: size 16gb, available 4484mb, required 16kb, differences 4484mb

Looks to me like there is plenty of space available. Does anyone have any idea what the real issue is here? Or more importantly what the solution is?

JeffCurless
04-11-2002, 09:35 AM
A little more information. While a normal install fails with a "out of disk space error", a silent install allows the install to continue, until during the file copy stage (around file #1500 or so) there is an attempt to copy a file to the "INSTALL/" directory. This location is not in the directory table, nor is it referenced anywhere within my install.

Looks to me like something is being overwritten, and that is causign the UI to perform an incorrect size calculation.

I used msiexec /I "adasdasd" /qn

Wise Guy
05-06-2002, 12:06 PM
I have had this reported by numerous win2k users now, is there any fix?

ThomasR
05-13-2002, 11:55 PM
I've just ran into this issue also. The target machine is running Win2k SP2, and had 4.0 GB free. Temp dirs had been cleaned up as well as a defrag. Yet when the installation was ran, the 1201 error ("...needs 8000 KB free disk space on drive C:\. Please free up some space and try again.") came up.

Interesting note: After scanning in some images to that machine, the install was tried again. The free disk space was now at 3.99 GB and the install ran fine. Instead of freeing up disk space, additional disk space was consumed.

Disk space calculation error when the available is greater than or equal to 4.0 GB?

Anything new on this issue?

johnline
07-12-2002, 02:39 PM
I have run into the same problem. I have 3 different release configurations in a project with various combinations of features. The smallest release configuation started giving me the 1201 error and the same message that I needed 8000 KB of disk space. I changed the line in the startup.ini file "diskspace=8000" to "diskspace=10000" and got the error saying I needed 10000 KB of disk space. Change the same line to "diskspace=0" and eveything ran fine.

mtupps
07-18-2002, 12:29 PM
Mine is a Standard Project and I am getting the same error ever since updating to 7.03

Marie

mdoepker
08-20-2002, 03:58 PM
Cleaning the temp directory worked for me as a work around when I ran into this problem. Although I don't see why this should be necessary. When the files are uncompressed is IS not overwriting previous temp files from other installs?

Does anyone know if InstallShield is actively pursuing this problem?

--Mark

nickgloe
11-04-2002, 09:06 PM
I experienced this recently when my installer was packaged and then extracted in winzip. When I deleted the files and then extracted them again, it went away. Strange.