PDA

View Full Version : How to install to Windows 2000 and and NT 4.0 SP<6 with one setup?



GBSdata
04-08-2002, 09:52 AM
Is this possible?
Default version of MSI is 2.0, but won't install on NT with SP <6.
I reverted to MSI 1.2 engine as described in Q105489.
Now W2K users get this error message.
"The installation package kan not be installed by the Windows Installer service. You must install an upgrade of the Windows Installer Service. It looks like my setup installs 1.2 even if 2.0 already exist on the target machine!!
Hence, I have to send all my W2k user version 2.0 by e-mail.
In ISpro 6.2 you only had to tick the OS you wanted to install on and everything was OK.
:confused:

Prince
04-08-2002, 11:25 AM
Genarally a setup created through older version of MSI can install properly on a machine having latest version of MSI engine. Your issue seems to be some strange behavior. You can try it at your end but installing MSI 2.0 engine on a w2k machine and then install a setup with MSI 1.2 engine.

ISD 7.03 would contain option for both MSI 1.2 and 2.0. This would be more comfortable in order to create setup for such type of machines.

_doog_
04-08-2002, 12:10 PM
the simplest way would be to revert back to version 1.1, which included within windows 2000