PDA

View Full Version : Error 267(?) On Windows 2000 Terminal Server



Oysteinl
04-08-2002, 05:20 AM
Hi

Basic Installsheild Developer Installation.

Windows 2000
Logged on as Administrator.

I am testing my installation on Terminal Server. I install through the Add\Remove programs, "Add New Program - CD or Floppy- Next - Browse (to network connection)"
The installation fires, but as soon as the select Language dialog appears I get.

"267 - Internal error in Windows Installer"

I can not seem to find this error in any documentation, except for the MSDN, and there it is connected to Microsoft SQL server.

I shall have full access to the folder that I am installing from and I am logged on as administrator. My installset functions as intended on all other OS.

- Anyone seen this error?

Prince
04-08-2002, 06:51 AM
The error 267 seems to be Windows error. I would suggest you to access the Disk1 folder and then launch setup.exe in order to install your setup.

_doog_
04-08-2002, 06:52 AM
if you look at the msi error codes, there is a line: errors from winerror.h may be returned as well

if you look up the error number in winerror.h, you will see:

267 The directory name is invalid. ERROR_DIRECTORY

---
do you install your software from a network share?
if so, try to copy it to a local drive first

Bloomerville
04-08-2002, 12:30 PM
I have had a similar problem in the past, installing on servers using Terminal Server. The problem is that even though you are logged in as an administrator through terminal server, the actual machine does not consider the terminal server session to have administrative rights. I have always had to install directly on the server. Now, I had a install condition that required the user to have admin privileges, if you just need to install a server or create registry entries, then you can use the custom action with "Deferred action run in system context" this gives the current session user temporary admin rights to perform the steps necessary for that custom action.

_doog_
04-08-2002, 12:33 PM
have you tried

termsrv install
(from command line)

before launching the installation?

Oysteinl
04-09-2002, 09:54 AM
Thank you for all response.

The error is still there, I am afraid, but I will continue to test further.

I have tried the:
- Installation from Local disc.
- Installation from Network disc
- Put the server in install modus (termsrv install)
- Add\remove programs (obviously)
- Admin from console.
- A Basic Installation set with only 1 component and no Custom Actions, just to rule out my main installations custom Actions.

Yet the error is still there.

I will try a new round of various updates, to see if that helps.