PDA

View Full Version : "Library not Registered" Error



swhelband
04-05-2002, 05:10 AM
I have just performed a clean install of Developer 7.0 and whenever I try and enter the application I receive the following error: -

"Library not registered"

upon clicking OK, the following dialog is then shown

"Failed to create empty document"

clicking OK again and the application closes.

Updating to 7.01 did not resolved the issue. Neither did upgrading from 7.01 to 7.02.

I am running this on Windows XP. There was a similar issue posted further down the forum but no response from Technical Support. Does anyone know of this issue??

Thanks

Simon Whelband

Prince
04-05-2002, 05:21 AM
Simon,

Have u performed dynamic scanning for your project ? It seems that some dependencies files are missing. Also, bbuild this project on Win2k machine and perform dynamic scanning. After scanning, include all the required files.

swhelband
04-05-2002, 05:43 AM
Thanks for the reply, but i haven't ANY projects...

This is a clean machine with no IS Projects on at all..

It's an XP machine (granted with various other dev tools installed), I then installed IS Developer and the error occurred upon the FIRST attempt to open up IS Developer.

Something in the installation of this product hasn't worked...that's all I can suggest. And the upgrades to both 7.01 and 7.02 didn't fix it either.

But as to what I don't know.

How can I find out what library hasn't been registered so I can manually register it?


Simon

Prince
04-05-2002, 05:47 AM
Simon,

Make sure that you have admin rights on that XP machine. I haven't seen any such problem. I have installed ISD 7.0 many times on XP machine and it installed without any problem. It seems that there is some problem with your machine itself. If you have any other XP machine then you can try on that machine and check results.

swhelband
04-05-2002, 05:56 AM
Yes i have administrative rights..(it's my own laptop).

As to installing onto another machine, I do have IS 7.01 installed on my ain workstation (to be upgraded shortly), but it doesn't really solve my problem...I am working away shortly and need ISD on my laptop as well.

At least one other person has had this error (who has posted to this forum anyways) so it IS an issue.

Just need a resolution or at least a way to work out what didn't work in the install...

Thanks for you input anyways.


SW

rresnick
08-12-2003, 01:08 PM
Just thought I would point out that I had this problem today with ISD 8 as well. Since I was able to eventually resolve it, I thought I'd pass on my comments for anyone else who gets stuck with this problem.

My circumstances: I had a W2K, SP2 machine on which I'd been running ISD 8 fine for a while (6 months or so).

I needed to upgrade this machine to XP, and of course didn't want to reformat my hard drive. I installed XP into a clean C:|Windows directory, leaving the original W2K installation still on the machine, so now it could dual-boot into either OS.

After installing the OS, I reinstalled each application I use (eg Visual Studio, etc.). When I got to ISD, I reinstalled from CD with typical settings. Installation went smoothly, no errors. However, when I tried to run ISD I got exactly what Simon reported. Namely I get teh ISD splash screen, then a dialog that says "Library not registered". When you click that away, get another dialog saying "Failed to create empty document".
Then the app exits. No further messages - <rant> really lousy diagnostics, IS support staff!</rant>

I tried installing again - same problem.

So, here's how I fixed it:
1. Uninstall ISD 8.0
2. Manually remove all IS installation files & directories from the file
system.
3. Walk the registry, and remove all IS related keys in HKCR, HKLM
4. Do a clean install of ISD 8.0 from CD.

Ugly, but that worked. It's installed & running fine now.

Good luck all.
Ron

SimoneRev
12-11-2003, 11:11 AM
That worked for me. I was having the same problem.