View Full Version : application not correctly removed after update

04-04-2002, 04:41 AM
I created an update (some product code and same version, diff. pack. code) with file differences, instead of complete files. In the patch wizard, I indicated to patch all installations with the same product code.
When applying the patch, I get error 1328. If I ignore the error, the patch continues.

But the real problem is when I remove the application using the add/remove panel. Everything is removed, except the files that have been patched. Why aren't they deleted?

For applying the patch, I used the command line:
msiexec /p patch.msp REINSTALL=ALL REINSTALLMODE=vos
msiexec /p patch.msp REINSTALL=ALL REINSTALLMODE=os

Both having the same result.

04-04-2002, 09:09 AM


04-04-2002, 09:51 AM
I just tried using INSTALLMODE=vomus.
I did, for some reason, not get the 1328 error, but it's probably unrelated.
But most of the patched files are still there after uninstalling the application on my development machine.

But the good news is, I tried it now on another (more clean) machine and there all files were removed after uninstallation.

Thanks for the reply.