View Full Version : MSDE Merge Modules

04-03-2002, 01:21 PM
I need a work around...... I currently have 3 features in my project. One of the features, called "MSDE", contains nothing but the MSDE merge modules. The project compiles fine. The setup seems to run correctly as long as I pick the "Typical" setup type which will install all 3 features. The problem occurs when I choose "Custom" setup and deselect the MSDE feature. This scenerio acts correctly on installation but there is a problem on "Removal" (or Maintenance in general). What seems to be happening is: Upon entering the Maintenance mode, I may choose any of the choices (Modify, Repair, Remove) and all of these componets will act as if MSDE was installed(even though it wasn't). So when the components try to act on MSDE, such as remove it, a FATAL ERROR occurs because the parameteres that are being searched for are not there. From here the setup is worthless because it is endlessly stuck in Maintenance Mode which will always run into the 1603 Fatal Error. (By the way, I tried to set Enable Maintenance mode to "No", but error still occurs).
I know I am not the only one with this problem, for I have seen it on the message boards before. But there has never been any fix posted that I have come across. I do not want to resort to a dual setup type install. If anyone else has dealt with this problem and knows a work around, I would appreciate a reply.
Thanx for your time......chaser

04-03-2002, 01:29 PM

When you launch your setup in Maintenance Mode and choose "Modify", is the Feature that contains this MSDE Merge Module selected or deselected?

(Assuming you DESELECTED this Feature during initial installation)



04-03-2002, 02:53 PM

Upon entering Modify in the maintenance mode, the check mark for the feature MSDE will be deselected. It will show the same check marks I set in the Custom installation.
If I install all features initially, then use modify in Maintenance mode and deselect MSDE, it will reinstall the selected features properly. BUT upon entering the setup the next time (in Maintenance mode) I will find the same fatal error when I choose and run any of the Modify, Repair, Remove components. I hope this info help you? thanx Chaser

02-05-2003, 08:34 PM

Did some one find a solution for this.
I too have the same problem.
It works fine when all the features are installed.
It fails when MSDE is not selected with 1603 error.
Please find the following error messgae
SOFTWARE\Microsoft\Microsoft SQL Server Setup.{92EA516A-FA81-4BC2-BF19-36594E0E6A95}
Error applying permissions to key
Action ended 8:12:37: SetServerRegKeyPrivileges.2D02443E_7002_4C0B_ABC9_EAB2C064397B. Return value 3.

Any help will be greatly appreciated.


02-05-2003, 10:44 PM

02-05-2003, 10:50 PM
I ended up creating a seperate install for MSDE2000 and call it from my applications installation. It works fine but still not the way i wanted to do it. I have not dealt with the problem since march\april for I forged through and moved on. But I am very interested if you find a fix. If you do please post.
thanx Chaser