PDA

View Full Version : Uninstall not removing a dll



David Kennedy
02-28-2002, 10:15 AM
I am using InstallShield Express 3.03 and created an install package to release a new version of a program that I am working on. I tested the release on several different computers and noticed something very strange.

Two of the computers that the release was tested on are running Windows 2000. The program was installed and then uninstalled on both boxes.

The install copies and registers 5 dlls. During the uninstall on 1 box 4 of the 5 dlls were removed. On the other box all 5 of the dlls were removed.

In InstallShield, all of the dlls are set to Use System Attributes, Self-Registration, and the Never Overwrite and Permanent boxes are left unchecked.

Has anyone seen this before or have an idea why the same uninstall might remove a dll on one computer but not the other?

AdamCurry
03-05-2002, 01:51 PM
Please post this question in the InstallShield Express community:
http://community.installshield.com/...p?s=&forumid=25

mkonanurcox
09-20-2005, 09:22 AM
I'm noticing the same problem with my InstallShield X package. My 2 dlls and 1 ocx file are not uninstalling on W2K and NT4 but are being removed on XP. I'm going to see if Ishield support can help.

jml089
10-01-2005, 08:45 AM
I am seeing the same problem in my InstallSheild Express Installation Project. Several files in the InstallDir, several Start Menu Shortcuts, and the ini file I create are not being removed by the uninstallation process.

How to fix?