View Full Version : INSTMSIA on a ME machine

02-22-2002, 08:34 AM
I just upgraded to ISX 3.53 and rebuilt my vb application's installation. It worked fine on a Win 98 machine; but, on an Me machine, the configuration of the Windows installer failed. After it configured the Windows installer and rebooted the machine I received the message "Unable to upgrade file %1 from file %2" and a few error messages relating to missing MSIA files. I tried manually running INSTMSIA and got the same messages after rebooting.

When I tried to run my installation, I received "MSIEXEC.EXE file is linked to missing export MSI.DLL:222." After researching this message on Google.com (did I say how much I love Google?) I learned the message was due to different versions of msiexe.exe and msi.dll. (Apparently the "unable to upgrade.." message referred to MSI.DLL.) I booted using a Win 98 diskette, upgraded the MSI.DLL file, and all was well.

The only open question is about the original error message when trying to upgrade from Windos Installer 1.2 to 2.0. All machines use Virus Scan. Could it be blocking on Me and not on Win 98?