PDA

View Full Version : Won't install to "MyPath"



jmarlow
01-21-2002, 06:20 PM
I am trying to create a transform for an application (NAVCE) to install to a directory of my choice. No matter what I do, it always installs to the default directory. My directory is outside of the ProgramFiles dir.

Mike Snyders
01-21-2002, 07:06 PM
Did you create a response transform or a blank transform?

Is the default destination path the only thing you have changed?

If not, are you seeing any of those other changes?

jmarlow
01-22-2002, 10:06 AM
I did create a response transform and changed only the installation path.

Quick divergence - the application is Symantec Nortan Antivirus Corporate Edition client.

Back to what I did. Once the wizard was complete, I went to the validation object to verify that the original .msi was OK. The validation gave me 1 error and 7 warnings. The error was ICE03 Invalid format string. The warnings were errors ICE46 (3), ICE66 (2), and ICE86 (2). I have used Tuner 1.0 in the past so I didn't think anything of these errors.

Next I checked the installation path. Previously this is where I would change the path. It was still showing the INSTALLDIR variable with the default location. I would have thought that the wizard would have changed this. It didn't, so I did. The new location is C:\OSTools\NAV.

I then ran the post validation and received the same errors/warnings. Lastly I built the package using the setup options with the /q for a quiet installation.

The package did install without showing any dialog boxes so something worked. I also tried a command line installation calling the .mst directly.

Help.... :(