PDA

View Full Version : BDE SQL Link Installation problem



NewsArchive
09-20-1996, 12:00 AM
Hi,

When I try using the IS Express Pro Eval to setup an installation with
SQL Server 6.5, there is an error message of "missing object"
when I run my program. I tested to see if the SQL connection is dead but
the result showed that the connection is fine but when I open the
install application, it blows with "missing object" error. Now if I use
Delphi 2.01 CD to install the BDe and SQL link drivers,, it WORKED! But
if I install the same thing using InstallShield, it dies. Anyone any
idea?

PS: I am using the Installshield Express Professional Evaluation copy
to prepare the installation.

--
===============================
Marcus Lam - - - mlam@hknet.com
===============================
Megatrend Information Services
===============================

NewsArchive
06-05-1997, 12:00 AM
Marcus Lam wrote:
>
> Hi,
>
> When I try using the IS Express Pro Eval to setup an installation with
> SQL Server 6.5, there is an error message of "missing object"
> when I run my program. I tested to see if the SQL connection is dead but
> the result showed that the connection is fine but when I open the
> install application, it blows with "missing object" error. Now if I use
> Delphi 2.01 CD to install the BDe and SQL link drivers,, it WORKED! But
> if I install the same thing using InstallShield, it dies. Anyone any
> idea?
>
> PS: I am using the Installshield Express Professional Evaluation copy
> to prepare the installation.
>
> --
> ===============================
> Marcus Lam - - - mlam@hknet.com
> ===============================
> Megatrend Information Services
> ===============================
My name is wen-ching wang
I call win32 api , my code is as follows,but I fail
why:(I got the answer from news discussion)
prototype BOOL user32.ExitWindowsA(LONG,LONG);
ExitWindowsA(0,0);
this is an am emergency
thanks.