PDA

View Full Version : Strange problem regarding Office 2000 shortcuts...



NewsArchive
12-10-2001, 01:00 AM
We've built a simple (read: no complex custom scripts as of yet) =
Installshield Developer 7 build of one of our software tools, and two =
people have run into a strange problem:

Our software tool is an add-in for Microsoft Excel (2000 or 97). The =
problem that is happening is that, after running our installer (which =
doesn't require a reboot), clicking the shortcut for our product, =
clicking a shortcut for Microsoft Excel, or clicking a shortcut or =
otherwise trying to launch any file in the MS Office suite, results in a =
Windows Installer window coming up asking them to stick in their Office =
CD, as if they've never had Office installed...even if they've already =
had Office installed for over a year. In one instance, the person had =
Word2k running WHILE running the installer, but when they tried to run =
Word2k a second time after the install it acted as if it wasn't =
installed...even though it was running at the time! A reboot appears to =
fix this problem (and, in fact, after a reboot, the people who had the =
problem are unable to reproduce it), but our tool has never required a =
reboot in the past, and there are no messages that come up to this =
effect anywhere during the install process. At first I thought it might =
have something to do with Dev7's needing to install the newer MSI engine =
"on the sly" and somehow that causing problems, but these problems =
happened on systems that have installed other Dev7-created installs of =
ours (including a previous version of the tool whose install caused all =
this in the first place!) in the past couple months or so with no =
problems whatsoever.

One person who is experiencing the problem is running Win2k and =
Office2k. The other is running WinNT and Office2k. That alone indicates =
to me that it is more likely related to Office2k than OS, since they're =
using different OSes.

So, I did a ton of testing on Friday, including:

Win98SE/Office97
WinNT/Office97
Win2k/Office97
Win98SE/Office2000
WinNT/Office2000

All of these combos worked fine for me and did not exhibit the behavior =
described above. I was completely unable to reproduce the problems.

I searched and searched online (the Web using Google, the USENET using =
Google Groups, the Installshield support knowledgebase, etc.). The only =
thing I could find that appeared to be directly related to this problem =
was a MS support knowledgebase article that exactly described the =
problem. However, it said that three conditions had to be met in order =
for the problem to crop up and I know for a fact that the two people =
here who had the problem only satisifed one of those three conditions. =
That, and (like I said earlier) they were unable to reproduce it =
themselves after a reboot.

Can anyone shed some light into what might be causing this and how to =
get around it? The "powers that be" here are very wary of releasing this =
new build to our users. One option that came up was forcing a reboot at =
the end of our tool's install, but they are extremely against that =
unless it's the only viable option.

Thanks in advance for any help on this,

--=20
Doug Thompson
James Gregory Associates, Inc.
doug.thompson@jgai.com

Beam4711
02-22-2002, 03:41 PM
Hi, I´ve got the same problem. Can you tell me how you solved it ? Can you tell me wehre to find that article you menioned ? didn´t found it till now ...

Thansk for your help

@Beam

Stefan Krueger
02-23-2002, 09:01 AM
I believe that's caused by the update of the windows installer engine to version 2.0. this REQUIRES a reboot, either immediately after the update, or at the end of your setup.
Note that earlier versions of Developer (version 7.00) did not use MSI 2.0 but 1.2, so if a older Developer setup has previously been installed, the mSI update still happens if the new setup was built with Developer 7.02.
Developer should automatically perform this reboot at the end of the install - however if your project was created with developer 7.00 and then migrated to 7.02 the required actions are not added by the upgrade tool. There's an article at http://kb.installshield.com that explains what you have to do to fix this.