PDA

View Full Version : Shortcuts are not removed



NewsArchive
12-07-2001, 01:00 AM
Hi all, a post my question again...

I have three independent setups created with ISD 7.01 (everyone is based on
one template ISD 7.01 project).
I changed product, package and update GUID of every one of them - all work
fine, but....
Every one create 2 shortcuts in the same folder "Programs\<My Company>".
If I install one product and then uninstall it the two shortcuts are
removed.
When I install all 3 products the shortcuts are removed only if I uninstall
them in the oposite order of installation...
How to remove corresponding shortcuts...
Is this a bug?

Thanks in advanced...

Ivan

NewsArchive
12-07-2001, 01:00 AM
I'm not sure, I have never tried this, and I do not know the finer details
about how the windows installer registers shortcuts. It may get confused in
a scenario like this.

I do not think this would be an advised solution if these are
MSI(Advertised) shortcuts. The reason is that an MSI shortcut needs to
reference its product code. When you install the same shortcuts with
different product codes who knows what is going to happen.

Have you tried creating shortcuts with explicit file references to see if
this changes the behavior at all?

Regards
David Thornley

"Ivan Furnadjiev" <ihf@vmei.acad.bg> wrote in message
news:3c10fa28$1@news.installshield.com...
> Hi all, a post my question again...
>
> I have three independent setups created with ISD 7.01 (everyone is based
on
> one template ISD 7.01 project).
> I changed product, package and update GUID of every one of them - all work
> fine, but....
> Every one create 2 shortcuts in the same folder "Programs\<My Company>".
> If I install one product and then uninstall it the two shortcuts are
> removed.
> When I install all 3 products the shortcuts are removed only if I
uninstall
> them in the oposite order of installation...
> How to remove corresponding shortcuts...
> Is this a bug?
>
> Thanks in advanced...
>
> Ivan
>
>
>

NewsArchive
12-10-2001, 01:00 AM
Question Ivan:

Do you have the same component id on the components that contains the
shortcuts in all the products?
If you have it could make some problems for you during uninstall...


--Rune G

"David Thornley" <davidt@installshield.com> wrote in message
news:3c110bf4$1@news.installshield.com...
> I'm not sure, I have never tried this, and I do not know the finer details
> about how the windows installer registers shortcuts. It may get confused
in
> a scenario like this.
>
> I do not think this would be an advised solution if these are
> MSI(Advertised) shortcuts. The reason is that an MSI shortcut needs to
> reference its product code. When you install the same shortcuts with
> different product codes who knows what is going to happen.
>
> Have you tried creating shortcuts with explicit file references to see if
> this changes the behavior at all?
>
> Regards
> David Thornley
>
> "Ivan Furnadjiev" <ihf@vmei.acad.bg> wrote in message
> news:3c10fa28$1@news.installshield.com...
> > Hi all, a post my question again...
> >
> > I have three independent setups created with ISD 7.01 (everyone is based
> on
> > one template ISD 7.01 project).
> > I changed product, package and update GUID of every one of them - all
work
> > fine, but....
> > Every one create 2 shortcuts in the same folder "Programs\<My Company>".
> > If I install one product and then uninstall it the two shortcuts are
> > removed.
> > When I install all 3 products the shortcuts are removed only if I
> uninstall
> > them in the oposite order of installation...
> > How to remove corresponding shortcuts...
> > Is this a bug?
> >
> > Thanks in advanced...
> >
> > Ivan
> >
> >
> >
>
>

NewsArchive
12-10-2001, 01:00 AM
Hi Rune G,
Yes...I changed product, package and upgrade codes...but components codes
are the same in all 3 setups...
Thanks for your suggestion...I will try to change them...

Ivan

"Rune G" <rg#world-online.no> wrote in message
news:3c14d19f@news.installshield.com...
> Question Ivan:
>
> Do you have the same component id on the components that contains the
> shortcuts in all the products?
> If you have it could make some problems for you during uninstall...
>
>
> --Rune G
>
> "David Thornley" <davidt@installshield.com> wrote in message
> news:3c110bf4$1@news.installshield.com...
> > I'm not sure, I have never tried this, and I do not know the finer
details
> > about how the windows installer registers shortcuts. It may get
confused
> in
> > a scenario like this.
> >
> > I do not think this would be an advised solution if these are
> > MSI(Advertised) shortcuts. The reason is that an MSI shortcut needs to
> > reference its product code. When you install the same shortcuts with
> > different product codes who knows what is going to happen.
> >
> > Have you tried creating shortcuts with explicit file references to see
if
> > this changes the behavior at all?
> >
> > Regards
> > David Thornley
> >
> > "Ivan Furnadjiev" <ihf@vmei.acad.bg> wrote in message
> > news:3c10fa28$1@news.installshield.com...
> > > Hi all, a post my question again...
> > >
> > > I have three independent setups created with ISD 7.01 (everyone is
based
> > on
> > > one template ISD 7.01 project).
> > > I changed product, package and update GUID of every one of them - all
> work
> > > fine, but....
> > > Every one create 2 shortcuts in the same folder "Programs\<My
Company>".
> > > If I install one product and then uninstall it the two shortcuts are
> > > removed.
> > > When I install all 3 products the shortcuts are removed only if I
> > uninstall
> > > them in the oposite order of installation...
> > > How to remove corresponding shortcuts...
> > > Is this a bug?
> > >
> > > Thanks in advanced...
> > >
> > > Ivan
> > >
> > >
> > >
> >
> >
>
>