PDA

View Full Version : Splash screens do not work / Custom Actions do not work.



NewsArchive
12-06-2001, 01:00 AM
I have IS Developer 7.01. I cannot add a Splash screen bitmap to the
project, because when the project builds (Compressed Build) I get errors. it
is trying to find the file under a path that does not exist.

** Error: -1007: Cannot copy source
C:\Projects\CSInstallations\DsServer\files\support\setup.bmp to target
C:\Projects\CSInstallations\DsServer\Product Configuration 1\Compressed
Install\DiskImages\DISK1\409 - English (United States)\setup.bmp

** Error: -5054: Could not determine the size of the file
"C:\Projects\CSInstallations\DsServer\Product Configuration 1\Compressed
Install\DiskImages\DISK1\409 - English (United States)\setup.bmp"

I hava added 2 install script functions and made custom actions that use
them. But when I added them to the Installation / Execute list (anywher in
the list does not matter) the installation will build. However when you run
it, it gets to the point where it says "generating custom actions" and then
says error "1603 -fatal error in installation".
Hey, what a helpful error message!!

So far I am convinced that 7.0x is a bug ridden peice of ****. Somebody
please tell me if they have these same errors.

my address is nick@digitronics.com

NewsArchive
12-06-2001, 01:00 AM
Nicholas,
Make sure Setup.bmp exists in the specified location. I tried many scenarios
and could not get the errors you mentioned. My guess is that your setup or
some of the files are being held in use by another process causing the
mentioned problems. Try a blank project with 1 Feature/Component and splash
bitmap from your windows folder to see if the same behaviors occurs.


"Nicholas Randal" <nick@digitronics.com> wrote in message
news:3c0fea0e@news.installshield.com...
> I have IS Developer 7.01. I cannot add a Splash screen bitmap to the
> project, because when the project builds (Compressed Build) I get errors.
it
> is trying to find the file under a path that does not exist.
>
> ** Error: -1007: Cannot copy source
> C:\Projects\CSInstallations\DsServer\files\support\setup.bmp to target
> C:\Projects\CSInstallations\DsServer\Product Configuration 1\Compressed
> Install\DiskImages\DISK1\409 - English (United States)\setup.bmp
>
> ** Error: -5054: Could not determine the size of the file
> "C:\Projects\CSInstallations\DsServer\Product Configuration 1\Compressed
> Install\DiskImages\DISK1\409 - English (United States)\setup.bmp"
>
> I hava added 2 install script functions and made custom actions that use
> them. But when I added them to the Installation / Execute list (anywher in
> the list does not matter) the installation will build. However when you
run
> it, it gets to the point where it says "generating custom actions" and
then
> says error "1603 -fatal error in installation".
> Hey, what a helpful error message!!
>
> So far I am convinced that 7.0x is a bug ridden peice of ****. Somebody
> please tell me if they have these same errors.
>
> my address is nick@digitronics.com
>
>

NewsArchive
12-06-2001, 01:00 AM
I know Marwan answered the question, but I want address the error message,
"1603 -fatal error in installation". This is how Msi.chm describes the
error. We are just displaying how Microsoft documents the error. If Msi
returns this error we are pretty much obliged to display the error and the
documentation error message MS provides.

I have looked many times for more meaningful error messages on the MS
website or any kind of information on what would cause this error and other
errors. Nothing.

Anyway, the 1603 error is a generic error. It seems to be returned anytime
something goes wrong.

Kent

"Nicholas Randal" <nick@digitronics.com> wrote in message
news:3c0fea0e@news.installshield.com...
> I have IS Developer 7.01. I cannot add a Splash screen bitmap to the
> project, because when the project builds (Compressed Build) I get errors.
it
> is trying to find the file under a path that does not exist.
>
> ** Error: -1007: Cannot copy source
> C:\Projects\CSInstallations\DsServer\files\support\setup.bmp to target
> C:\Projects\CSInstallations\DsServer\Product Configuration 1\Compressed
> Install\DiskImages\DISK1\409 - English (United States)\setup.bmp
>
> ** Error: -5054: Could not determine the size of the file
> "C:\Projects\CSInstallations\DsServer\Product Configuration 1\Compressed
> Install\DiskImages\DISK1\409 - English (United States)\setup.bmp"
>
> I hava added 2 install script functions and made custom actions that use
> them. But when I added them to the Installation / Execute list (anywher in
> the list does not matter) the installation will build. However when you
run
> it, it gets to the point where it says "generating custom actions" and
then
> says error "1603 -fatal error in installation".
> Hey, what a helpful error message!!
>
> So far I am convinced that 7.0x is a bug ridden peice of ****. Somebody
> please tell me if they have these same errors.
>
> my address is nick@digitronics.com
>
>

NewsArchive
12-06-2001, 01:00 AM
It only works with an uncompressed build.

"Marwan Tabet" <noreply@installshield.com> wrote in message
news:3c0ff40d$1@news.installshield.com...
> Nicholas,
> Make sure Setup.bmp exists in the specified location. I tried many
scenarios
> and could not get the errors you mentioned. My guess is that your setup or
> some of the files are being held in use by another process causing the
> mentioned problems. Try a blank project with 1 Feature/Component and
splash
> bitmap from your windows folder to see if the same behaviors occurs.
>
>
> "Nicholas Randal" <nick@digitronics.com> wrote in message
> news:3c0fea0e@news.installshield.com...
> > I have IS Developer 7.01. I cannot add a Splash screen bitmap to the
> > project, because when the project builds (Compressed Build) I get
errors.
> it
> > is trying to find the file under a path that does not exist.
> >
> > ** Error: -1007: Cannot copy source
> > C:\Projects\CSInstallations\DsServer\files\support\setup.bmp to target
> > C:\Projects\CSInstallations\DsServer\Product Configuration 1\Compressed
> > Install\DiskImages\DISK1\409 - English (United States)\setup.bmp
> >
> > ** Error: -5054: Could not determine the size of the file
> > "C:\Projects\CSInstallations\DsServer\Product Configuration 1\Compressed
> > Install\DiskImages\DISK1\409 - English (United States)\setup.bmp"
> >
> > I hava added 2 install script functions and made custom actions that use
> > them. But when I added them to the Installation / Execute list (anywher
in
> > the list does not matter) the installation will build. However when you
> run
> > it, it gets to the point where it says "generating custom actions" and
> then
> > says error "1603 -fatal error in installation".
> > Hey, what a helpful error message!!
> >
> > So far I am convinced that 7.0x is a bug ridden peice of ****. Somebody
> > please tell me if they have these same errors.
> >
> > my address is nick@digitronics.com
> >
> >
>
>

NewsArchive
12-06-2001, 01:00 AM
Ok, but why can I not have custom actions in the installation execute list.

"Kent Foyer" <kent@installshield.com> wrote in message
news:3c0ffb95$1@news.installshield.com...
> I know Marwan answered the question, but I want address the error message,
> "1603 -fatal error in installation". This is how Msi.chm describes the
> error. We are just displaying how Microsoft documents the error. If Msi
> returns this error we are pretty much obliged to display the error and the
> documentation error message MS provides.
>
> I have looked many times for more meaningful error messages on the MS
> website or any kind of information on what would cause this error and
other
> errors. Nothing.
>
> Anyway, the 1603 error is a generic error. It seems to be returned
anytime
> something goes wrong.
>
> Kent
>
> "Nicholas Randal" <nick@digitronics.com> wrote in message
> news:3c0fea0e@news.installshield.com...
> > I have IS Developer 7.01. I cannot add a Splash screen bitmap to the
> > project, because when the project builds (Compressed Build) I get
errors.
> it
> > is trying to find the file under a path that does not exist.
> >
> > ** Error: -1007: Cannot copy source
> > C:\Projects\CSInstallations\DsServer\files\support\setup.bmp to target
> > C:\Projects\CSInstallations\DsServer\Product Configuration 1\Compressed
> > Install\DiskImages\DISK1\409 - English (United States)\setup.bmp
> >
> > ** Error: -5054: Could not determine the size of the file
> > "C:\Projects\CSInstallations\DsServer\Product Configuration 1\Compressed
> > Install\DiskImages\DISK1\409 - English (United States)\setup.bmp"
> >
> > I hava added 2 install script functions and made custom actions that use
> > them. But when I added them to the Installation / Execute list (anywher
in
> > the list does not matter) the installation will build. However when you
> run
> > it, it gets to the point where it says "generating custom actions" and
> then
> > says error "1603 -fatal error in installation".
> > Hey, what a helpful error message!!
> >
> > So far I am convinced that 7.0x is a bug ridden peice of ****. Somebody
> > please tell me if they have these same errors.
> >
> > my address is nick@digitronics.com
> >
> >
>
>

NewsArchive
12-06-2001, 01:00 AM
Are you building on a windows filesystem or some other system like
ClearCase?

"Nicholas Randal" <nick@digitronics.com> wrote in message
news:3c0fff02$1@news.installshield.com...
> It only works with an uncompressed build.
>
> "Marwan Tabet" <noreply@installshield.com> wrote in message
> news:3c0ff40d$1@news.installshield.com...
> > Nicholas,
> > Make sure Setup.bmp exists in the specified location. I tried many
> scenarios
> > and could not get the errors you mentioned. My guess is that your setup
or
> > some of the files are being held in use by another process causing the
> > mentioned problems. Try a blank project with 1 Feature/Component and
> splash
> > bitmap from your windows folder to see if the same behaviors occurs.
> >
> >
> > "Nicholas Randal" <nick@digitronics.com> wrote in message
> > news:3c0fea0e@news.installshield.com...
> > > I have IS Developer 7.01. I cannot add a Splash screen bitmap to the
> > > project, because when the project builds (Compressed Build) I get
> errors.
> > it
> > > is trying to find the file under a path that does not exist.
> > >
> > > ** Error: -1007: Cannot copy source
> > > C:\Projects\CSInstallations\DsServer\files\support\setup.bmp to target
> > > C:\Projects\CSInstallations\DsServer\Product Configuration
1\Compressed
> > > Install\DiskImages\DISK1\409 - English (United States)\setup.bmp
> > >
> > > ** Error: -5054: Could not determine the size of the file
> > > "C:\Projects\CSInstallations\DsServer\Product Configuration
1\Compressed
> > > Install\DiskImages\DISK1\409 - English (United States)\setup.bmp"
> > >
> > > I hava added 2 install script functions and made custom actions that
use
> > > them. But when I added them to the Installation / Execute list
(anywher
> in
> > > the list does not matter) the installation will build. However when
you
> > run
> > > it, it gets to the point where it says "generating custom actions" and
> > then
> > > says error "1603 -fatal error in installation".
> > > Hey, what a helpful error message!!
> > >
> > > So far I am convinced that 7.0x is a bug ridden peice of ****.
Somebody
> > > please tell me if they have these same errors.
> > >
> > > my address is nick@digitronics.com
> > >
> > >
> >
> >
>
>

NewsArchive
12-07-2001, 01:00 AM
Building on windows xp.

"Marwan Tabet" <noreply@installshield.com> wrote in message
news:3c100cbe$1@news.installshield.com...
> Are you building on a windows filesystem or some other system like
> ClearCase?
>
> "Nicholas Randal" <nick@digitronics.com> wrote in message
> news:3c0fff02$1@news.installshield.com...
> > It only works with an uncompressed build.
> >
> > "Marwan Tabet" <noreply@installshield.com> wrote in message
> > news:3c0ff40d$1@news.installshield.com...
> > > Nicholas,
> > > Make sure Setup.bmp exists in the specified location. I tried many
> > scenarios
> > > and could not get the errors you mentioned. My guess is that your
setup
> or
> > > some of the files are being held in use by another process causing the
> > > mentioned problems. Try a blank project with 1 Feature/Component and
> > splash
> > > bitmap from your windows folder to see if the same behaviors occurs.
> > >
> > >
> > > "Nicholas Randal" <nick@digitronics.com> wrote in message
> > > news:3c0fea0e@news.installshield.com...
> > > > I have IS Developer 7.01. I cannot add a Splash screen bitmap to the
> > > > project, because when the project builds (Compressed Build) I get
> > errors.
> > > it
> > > > is trying to find the file under a path that does not exist.
> > > >
> > > > ** Error: -1007: Cannot copy source
> > > > C:\Projects\CSInstallations\DsServer\files\support\setup.bmp to
target
> > > > C:\Projects\CSInstallations\DsServer\Product Configuration
> 1\Compressed
> > > > Install\DiskImages\DISK1\409 - English (United States)\setup.bmp
> > > >
> > > > ** Error: -5054: Could not determine the size of the file
> > > > "C:\Projects\CSInstallations\DsServer\Product Configuration
> 1\Compressed
> > > > Install\DiskImages\DISK1\409 - English (United States)\setup.bmp"
> > > >
> > > > I hava added 2 install script functions and made custom actions that
> use
> > > > them. But when I added them to the Installation / Execute list
> (anywher
> > in
> > > > the list does not matter) the installation will build. However when
> you
> > > run
> > > > it, it gets to the point where it says "generating custom actions"
and
> > > then
> > > > says error "1603 -fatal error in installation".
> > > > Hey, what a helpful error message!!
> > > >
> > > > So far I am convinced that 7.0x is a bug ridden peice of ****.
> Somebody
> > > > please tell me if they have these same errors.
> > > >
> > > > my address is nick@digitronics.com
> > > >
> > > >
> > >
> > >
> >
> >
>
>

Kusum Wadekar
04-16-2002, 02:45 PM
I am getting this error too. How did you get rid of it, if you did.

Thank you.

Kusum Wadekar
04-16-2002, 02:49 PM
IN continuation with my earlier question. I noticed that the Target file - 409- English... does not get created under DISK1 .

** Error: -1007: Cannot copy source E:\iD 42 Products\iD 42 Install (Initial 1002)\setup files\uncompressed files\0009-english\os independent\setup.bmp to target E:\iD 42 Products\iD 42 Install (Initial 1002)\iD 42 Products\TESTMIGRATION2\Release 1\DiskImages\DISK1\409 - English (United States)\setup.bmp
** Error: -5054: Could not determine the size of the file "E:\iD 42 Products\iD 42 Install (Initial 1002)\iD 42 Products\TESTMIGRATION2\Release 1\DiskImages\DISK1\409 - English (United States)\setup.bmp"
Please e-mail t kwadekar@cincom.com. Would appreciate it.

Kusum Wadekar
04-16-2002, 03:34 PM
WORKED when built in UNCOMPRESSED mode.