View Full Version : PRODUCT_NAME looses last character???

12-21-2001, 04:26 AM
I've suddenly experienced quite a puzzling problem with Installshield 6.1, the @PRODUCT_NAME variable has lost its last character when accessed in the code. It looks ok in the Project/Settings/Owner menu. Any idea?


Mark at IS
12-21-2001, 09:48 AM
The value entered in Project|Settings|Application|Name does not determine the value of @PRODUCT_NAME (although both are initially set to the same value when the Project Wizard creates a project). The @ operator accesses a value that is set in the string table. You can view the string table by clicking the Resources pane's '<project name>' Resources\String Table\<language> entry.

Check the value of PRODUCT_NAME in the string table; correct it if necessary; then rebuild your setup and run it. If your problem still remains, you can request technical support at http://support.installshield.com/ask-via-web/.

12-21-2001, 09:55 AM
Well, I discovered that too after I posted my message. So I found PRODUCT_NAME in the string table, but it looked ok! I rebuilt and the same error occured, then I edited the PRODUCT_NAME in the stringtable, and rebuilt, and it looked ok, so I changed it back again and rebuilt and everything worked ok. Thought the problem was solved, but the next rebuild failed. Then I edited PRODUCT_NAME again, and all worked fine.