PDA

View Full Version : OLEAUT32.DLL problem with ISX 2



NewsArchive
07-19-1997, 12:00 AM

NewsArchive
07-21-1997, 12:00 AM
I am having the same problem and unfortunately, when this happens, OLE in
general is pretty well trashed on the target machine.

David Kubiak
tti

Valerio Oss <ossvale@tqs.it> wrote in article <33CFF364.20FDB770@tqs.it>...
> I have created an installation for a VB5 app with ISX 2.0 and it works
> fine in many machines I tried.
> On two machines, where there was an older version (ver 2.1) of the
> OLEAUT32.DLL,
> this file was NOT updated as it should have to the 2.2 version I have to
> install. This causes
> some OCXs and DLL not to be correctly registered: COMDLG32.DLL
> COMCTL32.DLL etc.
>
> Valerio Oss

NewsArchive
08-01-1997, 12:00 AM
David Kubiak wrote:
>
> I am having the same problem and unfortunately, when this happens, OLE in
> general is pretty well trashed on the target machine.
>
> David Kubiak
> tti
>
> Valerio Oss <ossvale@tqs.it> wrote in article <33CFF364.20FDB770@tqs.it>...
> > I have created an installation for a VB5 app with ISX 2.0 and it works
> > fine in many machines I tried.
> > On two machines, where there was an older version (ver 2.1) of the
> > OLEAUT32.DLL,
> > this file was NOT updated as it should have to the 2.2 version I have to
> > install. This causes
> > some OCXs and DLL not to be correctly registered: COMDLG32.DLL
> > COMCTL32.DLL etc.
> >
> > Valerio Oss

I got the same problem.!!
Hoe can i solve it?Anybody know that??
If i changed to Install shield 5 profession,will it
be solved??
Please reply to cocomo@ms1.hinet.net

Thanks.

NewsArchive
09-09-1997, 12:00 AM
We also have exactly the same problem!

I've made a very simple installation with Express 2.01 in which I only
install OLEAUT32.DLL For the file to be updated, the computer need
to be rebooted!

I've then made the same simple installation but this time using Express
1.11
and the OLEAUT32.DLL was installed properly without having to reboot!

So I wonder if Express 2.01 would be using in anyway the file OLEAUT32.DLL
which would explain why it could not update it because it is in use while
Express 1.11 does not use it and that way it can install it properly right
away!

Does this seem like a probable explanation? Is there a way make v2.01
install it correctly without having to reboot? I would prefer making my
setup
with v2.01 instead of going back to v1.11!

Thanks!

alain.jean@groupecadec.com




Cocomo Jang <cocomo@ms1.hinet.net> wrote in article
<33E19198.789B@ms1.hinet.net>...
> David Kubiak wrote:
> >
> > I am having the same problem and unfortunately, when this happens, OLE
in
> > general is pretty well trashed on the target machine.
> >
> > David Kubiak
> > tti
> >
> > Valerio Oss <ossvale@tqs.it> wrote in article
<33CFF364.20FDB770@tqs.it>...
> > > I have created an installation for a VB5 app with ISX 2.0 and it
works
> > > fine in many machines I tried.
> > > On two machines, where there was an older version (ver 2.1) of the
> > > OLEAUT32.DLL,
> > > this file was NOT updated as it should have to the 2.2 version I have
to
> > > install. This causes
> > > some OCXs and DLL not to be correctly registered: COMDLG32.DLL
> > > COMCTL32.DLL etc.
> > >
> > > Valerio Oss
>
> I got the same problem.!!
> Hoe can i solve it?Anybody know that??
> If i changed to Install shield 5 profession,will it
> be solved??
> Please reply to cocomo@ms1.hinet.net
>
> Thanks.
>

NewsArchive
10-04-1997, 12:00 AM
Alain Jean wrote:
>
> We also have exactly the same problem!
>
> I've made a very simple installation with Express 2.01 in which I only
> install OLEAUT32.DLL For the file to be updated, the computer need
> to be rebooted!
>
> I've then made the same simple installation but this time using Express
> 1.11
> and the OLEAUT32.DLL was installed properly without having to reboot!
>
> So I wonder if Express 2.01 would be using in anyway the file OLEAUT32.DLL
> which would explain why it could not update it because it is in use while
> Express 1.11 does not use it and that way it can install it properly right
> away!
>
> Does this seem like a probable explanation? Is there a way make v2.01
> install it correctly without having to reboot? I would prefer making my
> setup
> with v2.01 instead of going back to v1.11!
>
> Thanks!
>
> alain.jean@groupecadec.com
>
> Cocomo Jang <cocomo@ms1.hinet.net> wrote in article
> <33E19198.789B@ms1.hinet.net>...
> > David Kubiak wrote:
> > >
> > > I am having the same problem and unfortunately, when this happens, OLE
> in
> > > general is pretty well trashed on the target machine.
> > >
> > > David Kubiak
> > > tti
> > >
> > > Valerio Oss <ossvale@tqs.it> wrote in article
> <33CFF364.20FDB770@tqs.it>...
> > > > I have created an installation for a VB5 app with ISX 2.0 and it
> works
> > > > fine in many machines I tried.
> > > > On two machines, where there was an older version (ver 2.1) of the
> > > > OLEAUT32.DLL,
> > > > this file was NOT updated as it should have to the 2.2 version I have
> to
> > > > install. This causes
> > > > some OCXs and DLL not to be correctly registered: COMDLG32.DLL
> > > > COMCTL32.DLL etc.
> > > >
> > > > Valerio Oss
> >
> > I got the same problem.!!
> > Hoe can i solve it?Anybody know that??
> > If i changed to Install shield 5 profession,will it
> > be solved??
> > Please reply to cocomo@ms1.hinet.net
> >
> > Thanks.
> >
I too am looking for the answer. From what I understand so far, the
oleaut32.dll file is a required file for windows and therefore open when
windows is open. It makes sense that you would have to reboot to link
the new dll, but how do you get it on the target machine...thats the
question! Can a program be written to unlink and close the dll. If so,
then you could use the express extensions to launch that program and
copy the file, perhaps even reboot before continuing the install.

Help!!!

NewsArchive
11-22-1997, 01:00 AM
Did anyone get resolution to this? I am getting so frustrated trying to
find a way around this problem.



Jeff McDonald wrote:
>
> Alain Jean wrote:
> >
> > We also have exactly the same problem!
> >
> > I've made a very simple installation with Express 2.01 in which I only
> > install OLEAUT32.DLL For the file to be updated, the computer need
> > to be rebooted!
> >
> > I've then made the same simple installation but this time using Express
> > 1.11
> > and the OLEAUT32.DLL was installed properly without having to reboot!
> >
> > So I wonder if Express 2.01 would be using in anyway the file OLEAUT32.DLL
> > which would explain why it could not update it because it is in use while
> > Express 1.11 does not use it and that way it can install it properly right
> > away!
> >
> > Does this seem like a probable explanation? Is there a way make v2.01
> > install it correctly without having to reboot? I would prefer making my
> > setup
> > with v2.01 instead of going back to v1.11!
> >
> > Thanks!
> >
> > alain.jean@groupecadec.com
> >
> > Cocomo Jang <cocomo@ms1.hinet.net> wrote in article
> > <33E19198.789B@ms1.hinet.net>...
> > > David Kubiak wrote:
> > > >
> > > > I am having the same problem and unfortunately, when this happens, OLE
> > in
> > > > general is pretty well trashed on the target machine.
> > > >
> > > > David Kubiak
> > > > tti
> > > >
> > > > Valerio Oss <ossvale@tqs.it> wrote in article
> > <33CFF364.20FDB770@tqs.it>...
> > > > > I have created an installation for a VB5 app with ISX 2.0 and it
> > works
> > > > > fine in many machines I tried.
> > > > > On two machines, where there was an older version (ver 2.1) of the
> > > > > OLEAUT32.DLL,
> > > > > this file was NOT updated as it should have to the 2.2 version I have
> > to
> > > > > install. This causes
> > > > > some OCXs and DLL not to be correctly registered: COMDLG32.DLL
> > > > > COMCTL32.DLL etc.
> > > > >
> > > > > Valerio Oss
> > >
> > > I got the same problem.!!
> > > Hoe can i solve it?Anybody know that??
> > > If i changed to Install shield 5 profession,will it
> > > be solved??
> > > Please reply to cocomo@ms1.hinet.net
> > >
> > > Thanks.
> > >
> I too am looking for the answer. From what I understand so far, the
> oleaut32.dll file is a required file for windows and therefore open when
> windows is open. It makes sense that you would have to reboot to link
> the new dll, but how do you get it on the target machine...thats the
> question! Can a program be written to unlink and close the dll. If so,
> then you could use the express extensions to launch that program and
> copy the file, perhaps even reboot before continuing the install.
>
> Help!!!