PDA

View Full Version : Problems with old version of ocx's



NewsArchive
01-14-1997, 01:00 AM
Hello,

I'm using an evaluation copy and are having some problems with
distributing version 5.00 of "comctl32.ocx". On computers with version
1.0 already installed, something seems to go wrong. As i understand it
InstallShield Express does not unregister the old OCX, before
overwriting the old file with the new (That i am providing on my
installation disks). Is there a way round this or is this upgraded in
the sharp version of InstallShield Express?

Regards
Pontus Oldberg
IC Technologies

NewsArchive
01-16-1997, 01:00 AM
Pontus Oldberg wrote:
>
> Hello,
>
> I'm using an evaluation copy and are having some problems with
> distributing version 5.00 of "comctl32.ocx". On computers with version
> 1.0 already installed, something seems to go wrong. As i understand it
> InstallShield Express does not unregister the old OCX, before
> overwriting the old file with the new (That i am providing on my
> installation disks). Is there a way round this or is this upgraded in
> the sharp version of InstallShield Express?
>
> Regards
> Pontus Oldberg
> IC Technologies
Every one!

Take good care when installing Microsofts Vb5cce (VB 5.0). It will
overwrite the old comctl32.ocx and comdlg32.ocx which are not compatible
with VB 4.0. This is what created my problem. Workaround ?, yes you need
to reinstall the old ocx's register and reompile your VB 4 projects.

Unless you did what i did, i tested to compile my old VB4 project on
VB5, it worked fine... BUT. It automatically upgraded my project files
to recognize the new Active-X versions of comctl32 and comdlg32 which
are not backward compatible, so i spent some 5 hours fixing this. Thanks
a lot Microsoft.

Regards
Pontus