PDA

View Full Version : TLS 1.2 support in IS 2018 ?



vivekjazzwal
11-26-2018, 07:04 AM
Hi,

Does Installshield 2018 support TLS 1.2 environment where i can execute sql scripts using "SQL scripts" feature of InstallShield ?

Larry578
12-03-2018, 02:20 AM
we are in same boat. please help me, if you find any thing related to this query. and I also not able to update TLS 1.1 to TLS 1.2. Suggest me how can I do this?
kissanime (https://www.kissanime.vip/)

Roman1
12-03-2018, 03:18 AM
Update

https://support.microsoft.com/en-us/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-wi/

vivekjazzwal
12-05-2018, 04:26 AM
we are in same boat. please help me, if you find any thing related to this query. and I also not able to update TLS 1.1 to TLS 1.2. Suggest me how can I do this?

Hi Larry,

If you are using setup.exe, you can add a new pre-requisite for installing Microsoft latest MSOLEDBSQL driver and update the AdoDriverName coumn to 'msoledbsql' in ISSQLDBMetadata table.This should fix issue for TLS 1.2 and later environments.

Let me know if you find any other alternatives..

harold.olsen
02-15-2019, 04:07 PM
Hi Larry,

If you are using setup.exe, you can add a new pre-requisite for installing Microsoft latest MSOLEDBSQL driver and update the AdoDriverName coumn to 'msoledbsql' in ISSQLDBMetadata table.This should fix issue for TLS 1.2 and later environments.

Let me know if you find any other alternatives..

The solution we used (in IS2015) was to direct edit the SQLServer ISSQLDBMetaData from the oledb driver to the newer driver "sqlncli11". The line should look like:
<row><td>MSSQLServer</td><td>Microsoft SQL Server</td><td>sqlncli11</td> ....
We had to manually insure the right version of the native driver because the IS pre-req version wasn't adequate..