PDA

View Full Version : Problem signing compressed setup



-RobSzy-
07-14-2017, 06:37 AM
Hi to everyone,

I've got problem signing my setup - and I have to say that I'm new in creating setups and signing...

I have a "basic msi project" and with a configuration with no compression for the setup my msi package will be signed correctly - that good :) That's what I want :)

But when I put on the compression with optimation type MSZIP the msi package won't be signed. I can see that when I try to install my app, the typical message box appears saying that it's a unknown publisher. But in the output window eveything looks fine - here an example:

...
4>Language English (United States) built
4>Building .cab files...
4>Data1.cab built
4>Files built
4>Media table successfully built
4>Started signing certificate.msi ...
4>Performing Upgrading and Patching Validation
4>Started signing WinVisco.msi ...
4>Setup.exe created
4>Started signing setup.exe ...
4>Windows validation is disabled. To enable Windows validation: on the Tools menu, click Options and select the Validation tab.
4>Automatic update notification disabled
4>Default Configuration\Debug - 0 error(s), 0 warning(s)
...

Under "signing tab" I have activated signing for setup.exe and windows installer package - so it should work.
Anyone an idea why I can't sign a compressed setup? Is it normal?

Thanks and have a nice weekend - Rob

----------------

I'm using IS2016 Professional and VisualStudio 2015.

-RobSzy-
07-14-2017, 07:14 AM
Update:
Well, maybe it's my fault: Under windows 7 everything looks fine, but under windows vista i have the problem described above... hmm... I will have a closer look at it on monday :)

Have a nice weekend - Rob :)

-RobSzy-
07-17-2017, 11:27 PM
Hi,

yesterday I've had a closer look on my problem, the resulst is that it seems to be a vista specific problem. Installing my product under windows 7 caused no problem, windows 8, 8.1 & 10 also no problem with the certificate / signing.

So I tried to install other programs in Vista like "Adobe Reader" and an addon for the virtual machine from "oracle" I'm using. Both of them had the same problem ("unknown publisher") just like my installation. So I think it's a vista specific thing I can ignore :)

So sorry for creating this thread so fast - have a nice day

- Rob -

chad.petersen
07-18-2017, 09:16 AM
Just FYI: Vista is no longer supported by Microsoft. I pity those who have to support an operating system that Microsoft no longer supports - not even sure how you can do that.

Read here: https://support.microsoft.com/en-us/help/13853/windows-lifecycle-fact-sheet

Chad