PDA

View Full Version : Error trying to test the Single_EXE_Image



Maheshwar_Deo
07-11-2017, 02:28 PM
Hello,

We inherited from another company a windows application that has installation project using install shield.

The installshield project was developed using earlier version if installshield, so updated the project and resolved all the path variables and was able to compile and create the executable.

When installing it doesn't complete the installation and fails with error messages.

When trying to test the project using the Test Single EXE Image, I am getting the error of

"Error opening installation log file. Verify that the specified log file location exists and is writable".

I don't see any log variables set up for logging but see that in the installscript under that path of installer they are trying to create a log file.

Help needed. Please let me know, of there is a number that I could reach and talk to you about the issue.

Thanks,
Mahesh.

chad.petersen
07-12-2017, 09:48 AM
Under the Build menu is a Settings... choice. Once the Settings dialog comes up go to the MSI Log File and make sure that the settings in there are either cleared or are appropriate.

The log file can only be written to a folder that exists. The log file and MSI will not create a folder if it doesn't exist - for the log file.

You had mentioned the InstallScript trying to write to a log file. That would likely have a different error or message since InstallScript isn't going to cause the dialog you are showing to pop up. That's coming from the built-in logging ability - InstallScript might trigger the same message, but I sort of doubt that.

On this forum there are almost no replies from Flexera Software. Just a few of us users that are sharing information and trying to help. If you need help from Flexera their support location is

http://support.flexerasoftware.com/

Chad