PDA

View Full Version : BDE 3 not updating to BDE 4



NewsArchive
09-29-1997, 12:00 AM
After installing Delphi 3 app to platform with existing BDE, app fails to
run citing older BDE version problem. In fact, both BDE version 3 and 4
are now installed on target system but BDE 4 will not run. BDEAmin.exe
cannot even run citing the same older version problem.

What is the problem? I think previously I saw something about BDE problems
and a fixe in the ISX 2.01. Is that what I need?

Greg Fordham
greg@knfcon.com

NewsArchive
09-29-1997, 12:00 AM
On 29 Sep 97 13:33:23 GMT, "Greg" <greg@knfcon.com> wrote:
>After installing Delphi 3 app to platform with existing BDE, app fails to
>run citing older BDE version problem. In fact, both BDE version 3 and 4

What BDE installation did you use? Partial or Full? If you used a Partial
Install, please make it a Full Install. Also try to find out where the BDE
was installed on that target machine.

Stefan
ellipse data systems

NewsArchive
09-30-1997, 12:00 AM
You should be able to overwrite a previous version of BDE. However, I have
read that it is recommends a complete uninstall of the previous version of
BDE before installing the new one. Also, Express 2.01 did resolve some BDE
issues that existed with 2.0. However, I cannot tell you for sure if it
will resolve your problem.

Kent
InstallShield Technical Support

Greg <greg@knfcon.com> wrote in article <01bcccdc$05d5cb60$4ff845cf@k-f>...
> After installing Delphi 3 app to platform with existing BDE, app fails to
> run citing older BDE version problem. In fact, both BDE version 3 and 4
> are now installed on target system but BDE 4 will not run. BDEAmin.exe
> cannot even run citing the same older version problem.
>
> What is the problem? I think previously I saw something about BDE
problems
> and a fixe in the ISX 2.01. Is that what I need?
>
> Greg Fordham
> greg@knfcon.com
>

NewsArchive
10-02-1997, 12:00 AM
If you are *Upgrading* your 32-bit BDE installation, then install
version 4 in the same directory you installed version 3.x
This will *update* the DLL's and as a benefit, you will retain all
drivers and aliases configured in the previous version.
BTW - I have yet to find an un-install option for the BDE alone -
Delphi, yes - BDE, no.