PDA

View Full Version : SigningHelper: error 0x80072efd while attempting to sign file



Slippy
05-24-2017, 07:55 AM
I get the above error on my build-server with the standalone build tool of InstallShield. If I build the same project locally on my computer, everything is fine.

chad.petersen
05-24-2017, 09:44 AM
I'm not seeing any other reports of that error, but an error can be pretty unique at times - if I were running into an error like that I would for sure contact Flexera software directly. Do you have a support agreement with them?

Chad

chad.petersen
05-24-2017, 10:44 AM
Also, if you have not tried SP1 or SP2 that might be worth a try.

Chad

Slippy
05-26-2017, 06:18 AM
I tried SP1 and SP2, same error :(.

I just contacted Flexera.

installer96
05-31-2017, 02:09 PM
I'm receiving a similar error (0x80072ee2). Have you had any luck?

deramor
05-31-2017, 05:19 PM
I have entered a support ticket for this issue. I'll post an update if no one else does.

deramor
06-01-2017, 03:41 PM
My particular issue was that I had previously edited my Settings.xml file to use a timestamp server that had since been discontinued.


Your settings.xml file in InstallShield\2016 SAB\Support\0409 should have the following setting in it:
<DigitalSignature Timestamp="http://timestamp.verisign.com/scripts/timstamp.dll"/>

Mine was different.

Slippy
06-13-2017, 01:34 AM
Here it is an network problem. Our IT restricts internet access to our build machines so that the verification of the certificate fails. When I enable internet access on the build machine, then everything works fine.
Now we have to determine which IPs we have to enable :D.