PDA

View Full Version : Internal Error 2705. Directory



NewsArchive
12-05-2001, 01:00 AM
I am running into this run-time "Internal Error 2705. Directory". The
InstallShield failed with the message said "1628: Fail to complete
installation". I checked the error code 1628 from msi, which said "Invalid
or unknow table specified". How can I find out the cause of the error?

Please help!

Fanny

NewsArchive
12-06-2001, 01:00 AM
This means that your directory table is corrupted. This usually happens
when you have a directory entry that references something non existent as
its parent. I think that if your run validation on the MSI package it will
tell you which directory entry is having the problem. You could then use
the direct editor to correct this condition.

Regards
David Thornley

"fanny" <fxiao@emware.com> wrote in message
news:3c0ec6d3$1@news.installshield.com...
> I am running into this run-time "Internal Error 2705. Directory". The
> InstallShield failed with the message said "1628: Fail to complete
> installation". I checked the error code 1628 from msi, which said "Invalid
> or unknow table specified". How can I find out the cause of the error?
>
> Please help!
>
> Fanny
>
>

dijung
02-19-2002, 08:53 AM
Hi,

we got the same error "2705 Directory" during installer runtime. (No errors on MSI build time!)

After using DirectEditor on the msi, an empty parent dir entry for INSTALLDIR was found.

Then it turned out that in my ISD7 project in "General Information/Product Properties" the INSTALLDIR variable was empty. I swear I did not erase that! It was simply gone.

After entering the correct setting again the 2705 was gone.

solomon4yk
06-09-2015, 12:37 PM
Hello!

I have experienced the same kind of problem.
After some investigation and reading several posts I decided to look inside the .isl file. I found broken link to the ProgramMenu Shortcut. After removing corresponding entries the problem was fixed.

How did I get broken link to the shortcut.
1. Inside the ProgramMenu Predefined Folder I created needed folders (the same folders as in INSTALLDIR).
2. In Project Assistant \ Application Shortcuts I created needed shortcut.
3. After installing the application I got 2 same folders in ProgramMenu, one of which was empty.
4. I removed these folders from ProgramMenu Predefined Folder and noticed that in Project Assistant \ Application Shortcuts previous shortcut was gone.
5. I created shortcut again, and then got the error.

Hope it will help somebody.

Regards
Paul

[QUOTE=NewsArchive;88399]This means that your directory table is corrupted. This usually happens
when you have a directory entry that references something non existent as
its parent. I think that if your run validation on the MSI package it will
tell you which directory entry is having the problem. You could then use
the direct editor to correct this condition.

Regards
David Thornley