PDA

View Full Version : IS 2016 SP1 undocumented changes



clairealex
03-03-2017, 10:32 AM
I have upraded our build machine with IS 2016 SP1 yesterday. And suddenly, our suite installer was not working anymore. After researching the issue, we found out that now, the setup.exe is being copied to a temp dir and renamed to a random name before being executed.
for example, thsi is the beginning of the suite install log:
Engine: we're running from C:\Users\ALA~1\AppData\Local\Temp\{D863CF9B-54E7-4653-BD30-CC4FE1C77D09}\_isA974.exe

And the command-line, later is
Command Line: /log"C:\ProgramData\Installation\Blah_20170302-161534" -IS_temp ORIGINALSETUPEXEDIR="\\da\Daily Builds\build" ORIGINALSETUPEXENAME="SC Setup.exe" /debuglog"C:\ProgramData\Installation\Blah_20170302-161534\SC Installation.log"

These ORIGINALSETUPEXEDIR and ORIGINALSETUPEXENAME properties are not documented, as far as I know.

Just wanted to share this info, in case someone runs into an issue like ours.

Hysteresis
03-06-2017, 12:05 PM
Very interesting. Thanks for the heads up.

I also found an issue with suite installs and IS 2016 SP1 - see https://community.flexerasoftware.com/showthread.php?222402-Suite-package-install-detection-condition-failing-with-IS-2016-SP1

Because of this I've had to backout IS2016 SP1 from our build environment and revert to the original release verson of IS2016. I only use Basic MSI setup projects in conjunction with the suite though and so this won't affect everyone.

kmoulton
01-24-2018, 02:08 PM
We are trying to move to InstallShield 2018. I noticed this issue and then searched to findout what was posted.

This change has broken a lot of things in our installs.

Thanks for posting it. It confirms what I am seeing.

--Kim

kmoulton
01-24-2018, 02:40 PM
It is documented with the SUITE properties in InstallShield 2018,