PDA

View Full Version : VC++ 2010 redistributable not installed on Windows 10



rschoeller
02-22-2017, 02:28 AM
For our Program we need MS .NET Framework 3.5 SP1 as well as MS VC++ 2010 redistributable. I included both in the "Redistributable"-Section of our Install-Shield project.

On Windows 7 the generated installer works fine and both redistributables were installed. On Windows 10 on the other hand only the .NET Framework is installed and our program wouldn't start. Can you tell me, what I need to do, to get VC++ 2010 installed on Windows 10 as well?

rschoeller
02-22-2017, 02:55 AM
Here an extract from the InstallShield.log. Apparently the InstallShield seems to think that VC++ is already installed (it is not). Why is that?


2-21-2017[07:46:55 AM]: Checking setup prerequisite 'Microsoft Visual C++ 2010 Redistributable Package (x86).prq'
2-21-2017[07:46:55 AM]: Prerequisite 'Microsoft Visual C++ 2010 Redistributable Package (x86).prq' scheduled before feature selection
2-21-2017[07:46:55 AM]: Extracting 'Microsoft Visual C++ 2010 Redistributable Package (x86).prq' to C:\Users\IEUser\AppData\Local\Temp\{B01B0AF1-D16F-4782-9066-D139A878C7C2}\Microsoft Visual C++ 2010 Redistributable Package (x86).prq
2-21-2017[07:46:55 AM]: PrereqEngine: condition,1,2,HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{196BB40D-1578-3D01-B289-BEFC77A11A1E},,, -- Successful
2-21-2017[07:46:55 AM]: PrereqEngine: operatingsystemcondition,5, -- Failed!,
2-21-2017[07:46:55 AM]: PrereqEngine: operatingsystemcondition,6, -- Failed!,
2-21-2017[07:46:55 AM]: PrereqEngine: operatingsystemcondition,5, -- Failed!,
2-21-2017[07:46:55 AM]: PrereqEngine: operatingsystemcondition,6, -- Failed!,
2-21-2017[07:46:55 AM]: PrereqEngine: operatingsystemcondition,6, -- Failed!,
2-21-2017[07:46:55 AM]: PrereqEngine: operatingsystemcondition,5, -- Failed!,
2-21-2017[07:46:55 AM]: PrereqEngine: file,B88228D5FEF4B6DC019D69D4471F23EC,<ISProductFolder>\SetupPrerequisites\VC 2010 Redist\x86\vcredist_x86.exe,http://download.microsoft.com/download/5/B/C/5BC5DBB3-652D-4DCE-B14A-475AB85EEF6E/vcredist_x86.exe,,, -- Successful,
2-21-2017[07:46:55 AM]: PrereqEngine: execute,vcredist_x86.exe,/q,/q,1641,3010,, -- Successful
2-21-2017[07:46:55 AM]: PrereqEngine: dependency,<ISProductFolder>\SetupPrerequisites\Windows Installer 3.1 (x86).prq, -- Successful
2-21-2017[07:46:55 AM]: PrereqEngine: Id,{83960519-644A-4722-BA7A-37D23C1D004F},http://saturn.installshield.com/is/prerequisites/microsoft visual c++ 2010 redistributable package (x86).prq, -- Successful
2-21-2017[07:46:55 AM]: PrereqEngine: behavior,Optional,,Reboot,2,Failure,
2-21-2017[07:46:55 AM]: PrereqEngine: Lua,
2-21-2017[07:46:55 AM]: PrereqEngine: Hidden,
2-21-2017[07:46:55 AM]: PrereqEngine: MsiProgress,
2-21-2017[07:46:55 AM]: Skipping prerequisite 'Microsoft Visual C++ 2010 Redistributable Package (x86).prq' because it was installed before the reboot
2-21-2017[07:46:55 AM]: Prerequisites returning 0

rschoeller
02-23-2017, 04:20 AM
Any hints?

hidenori
02-23-2017, 12:06 PM
Have you tried the MS VC++ 2010 SP1 redistributable?

rschoeller
02-27-2017, 03:31 AM
Thanks!!! It worked!