View Full Version : Can't download prerequisite yet I am an Administrator of the computer

02-01-2017, 07:02 PM
Hi I hope someone can help!

Trying to download prerequisite "Microsoft SQL Server 2016 Express RTM (x64)".
Downloading 1 files.
Failed to download
C:\Program Files (x86)\InstallShield\2016\SetupPrerequisites\SQLServerExpress\2016\x64\SQLEXPR_x64_ENU.exe
Downloading Finished. 0 file(s) downloaded successfully. 1 file(s) failed to download correctly.

The download failed; make sure you are running as Administrator, and that your machine is connected to the Internet. Would you like to try again?
Yes No

* Windows Server 2016
* User account used is a domain user with Administrator privileges to the server
* InstallShield 2016

I just downloaded "Microsoft ,.NET Framework 4.5.2. Full" without issues.... so I believe it might be related to the SQL Server 2016 prerequisites themselves.
Downloading 1 files.
Successfully downloaded
C:\Program Files (x86)\InstallShield\2016\SetupPrerequisites\Microsoft .net\4.5\Full\NDP452-KB2901907-x86-x64-AllOS-ENU.exe
Downloading Finished. 1 file(s) downloaded successfully. 0 file(s) failed to download correctly.

Please if someone could explain.

02-01-2017, 09:59 PM
Also just logged in as the Computer\Administrator and they can't download the sql server 2016 prerequisite either... something is amiss with Install Shield.

02-03-2017, 10:03 AM
I don't work for Flexera at all, but thought I would chime in to let you know I tried the same in IS2016 (not SP1) just now and got the same exact thing.

I need to install SP1 anyway, so I'll install that and try it again. There's a chance that they might have fixed it, I suppose.


02-03-2017, 10:54 AM
Hate to report that I installed 2016 SP1 and still got the same error that you mentioned when downloading SQLEXPR_x64_ENU.exe

Do you have a support contract with Flexera? I'm going to file a case with them using my support contract. I might even call them after I submit the case just to get a faster take on the issue. Could affect us soon.


02-03-2017, 11:44 AM
OK, I opened a case with them online and then called them and they are investigating that.

In the meantime they gave a workaround verbally and I then worked on the specific steps for a little bit. It's pretty simple.

Download the file from here https://download.microsoft.com/download/E/1/2/E12B3655-D817-49BA-B934-CEB9DAC0BAF3/SQLEXPR_x64_ENU.exe

Into your C:\Program Files (x86)\InstallShield\2016\SetupPrerequisites\SQLServerExpress\2016\x64 folder

Close your project if it was opened.

Reopen the project

That seemed to get it working for me. I pulled the download site right out of the PRQ file using the right-click Edit Prerequisite choice and going to the "Files To Include" tab and with the SQLEXPR_x64_ENU.exe selected choosing the "Modify" button. You'll see it in the "URL to file:" entry.


02-05-2017, 06:04 PM
Awesome, thanks for letting me know and having a go.

I downloaded SQL Server SP1 2016 Express and put it in the folder.
I figure I could have just created a new prerequisite to point to it as well in another location.

I thought it was a problem with our new development server but good to get validation that its a InstallShield product issue rather than our new server's setup.

Your URL didn't work for me. So maybe the issue isn't Flexera's but more Microsoft's? I have to download a web installer to then download the SQL Server 2016 SP1 Express.
So if the link is now randomly generated for all users downloading SQL Server the URL will not work for it?

02-05-2017, 06:17 PM
I went here

Went down to the section
Get the core Express database server that includes the Database Engine feature only. Use this if you need a lightweight download and install, need to accept remote connections or administer remotely, yet don’t need the Reporting Services or Full Text Search features.
Which then downloaded the "SQLServer2016-SSEI-Expr.exe"

Then from within that application I could download SQL server sp1 express to a location on my computer.

Then once downloaded I copied it into installshield's prerequisite location.

02-05-2017, 07:23 PM
Oh the file SQLEXPR_x64_ENU.exe is a self extracting zip.
So calling it with the command line parameters doesn't work.
Need to call the setup.exe with them instead.

For this reason I kept SQL Server setup as a separate process and not done through install shield. However there are too many IT guys out there that have no experience with SQL Server setup and they really don't want to learn it either. So hence why I am back trying to get installShield to install it.
We had it going once upon a time but something between Microsoft and InstallShield stopped it from running and Microsoft where not going to fix it.

Oh I just found this guys how to

02-06-2017, 01:10 AM
I thought I had it working but it looks like its stuck on "Install_DoNet46_Cpu64_Action".

I edited the prerequisite to add a new file launch.bat.
Then the prerequisite launches the .bat file which extrats and then runs the setup.exe with the commands.

cmd /C start /wait SQLEXPR_x64_ENU.exe /q /x:"c:\SQLEXPRWT_x64_ENU"

02-06-2017, 07:00 PM
Answer me this please Flexera, Why do you provide SQL Server prerequisites with your application when Microsoft have clearly illustrated that SQL Server will not work with InstallShield!

To work around this issue, run the SQL Server setup program directly from the SQL Server installation media without wrapping the Setup program inside InstallShiled or a bootstrapping application.

For SQL Server 2014 and SQL Server 2012 SP2 and later versions, run the SQL Sever setup program together with SkipInstallerRunCheck command line parameter to skip Windows Installer handle check:
Setup.exe /SkipInstallerRunCheck

Flexera needs to update the way Microsfot SQL Server prerequsites are handled so the users of the the InstallShield software can install SQL Server and its prerequisites. Otherwise whats the point of having them in the list of prerequisites?

02-06-2017, 07:11 PM
Oh **** the default command line for the prerequisites are

Specify the command line for the application:
/qs /ACTION=Install /FEATURES=SQLEngine /INSTANCENAME=SQLEXPRESS /IAcceptSQLServerLicenseTerms /SkipInstallerRunCheck

Specify the command line for the application when the setup is running in silent mode:
/q /HIDECONSOLE /ACTION=Install /FEATURES=SQLEngine /INSTANCENAME=SQLEXPRESS /IAcceptSQLServerLicenseTerms /SkipInstallerRunCheck

And I was using my set

So i will get off my high horse now.