PDA

View Full Version : Error finding Win32 VM pack - Out of Memory



Jeff Kehoe
09-29-2016, 05:01 PM
I started getting this error today when I tried to build the windows config of our installer from a command line. I was building with no problems earlier in the day. I made no configuration changes.

Does anyone have any idea what might have gone wrong, or where it should be looking for the missing VM?

This is from the buildlog.xml:

<Build Error type="Non-Fatal Error" description="Error finding Win32 VM pack. &quot;oracle_jre7u45_windows_x64.vm&quot; Build using OracleJRE170u60_Win(x32).vm (Oracle JRE 7_60 Windows(x32))."/>
<Build Error type="Fatal Error" description="Installer Build has failed due to an Out of Memory condition."/>

Jeff Kehoe
09-30-2016, 09:53 AM
OK, I can't understand why the build executable suddenly stopped working. In my "InstallAnywhere 2014 SP1/resource/installer_vms" directory are two oracle .vm files (32 & 64 bit). Does anybody know why the build can find these vms?

I've increased the max heap in InstallAnywhere.lax file by 4 times and the result is the same.

Anybody from Flexera listening?

Jeff Kehoe
10-03-2016, 11:47 AM
Seriously is anyone from Flexera watching or listening?

bestellen
02-24-2017, 09:55 AM
Did you find idea about this issue?

jerome_IA
07-04-2017, 07:58 AM
Hi,

Did you tried increasing max heap size? lax.nl.java.option.java.heap.size.max in <IAHOME>\InstallAnywhere.lax

--Jerome