PDA

View Full Version : ISDEV : error -7354 after upgrade from 2013 in Error table



mbrock
09-08-2016, 11:36 AM
I upgraded my projects from 2013 to 2016, and now one of them is throwing the following error during compile:

ISDEV : error -7354: The Turkish: Türkçe value for string 'IDS_ERROR_2740' does not contain a legitimate value for table Error column Message

No error was thrown for 2013 and the string has not been modified. Additionally, all of our other languages (English, Spanish, Russian, Italian, Chinese (Simplified), German) compile without error.

I'm not sure how well it will come through, but here is the value for the string in question:

[2] özel eylemi [3] betik hatas?], [4]: [5] Sat?r [6], Sütun [7], [8].

hidenori
09-08-2016, 02:47 PM
The error -7354 has been introduced to InstallShield 2016 as documented in the Localized String Considerations topic under the Project Upgrade Alerts section of InstallShield 2016 Release Notes (http://helpnet.flexerasoftware.com/installshield23helplib/ReleaseNotes.htm). There seems to be no matching open bracket to the close bracket right after the question mark in your string. If you want to include a literal close bracket, you need to escape the character as follows:

[2] özel eylemi [3] betik hatas?[\]], [4]: [5] Sat?r [6], Sütun [7], [8].

Hope that helps.

mbrock
09-08-2016, 03:34 PM
Thank you Hidenori. Escaping the bracket fixed the issue.