PDA

View Full Version : Repackager (15.0.0.694) crashes during second snapshot



Martin
08-02-2016, 06:36 AM
The Repackager (15.0.0.694, part of AdminStudio 2016) crashes when creating the second snapshot. (Multiple Steps repackaging method).

Repackaging a small product (+/- 66 files) succeeds but a large product (> 4500 files) gives a crash of the repackager. Repackaging
the large product with an older version of the Repackager succeeds without issues. I don't exactly know what number of files results
in a crash of the repackager. It's somewhere between 66 en 4500.

I tried different large products on different platforms (Windows 7, 32 bit and Windows 10, 64 bit) with the standalone repackager installation
and the complete AdminStudio 2016 (evaluation) installation but the Repackager keeps crashing. The three required C++ prereq's (2008,
2010 and 2012) are correctly installed.

Installation monitoring as snap technology works on the lager products but we prefer to use the "multiple steps" method.

Any idea how to solve this?

Alpesh
08-02-2016, 10:59 PM
Hi,

You may be running into this issue --> https://flexeracommunity.force.com/customer/articles/en_US/ERRDOC/Repackager-Crashes-on-Windows-7-when-the-time-zone-is-not-set-to-a-US-time-zone. Please try running the VM in US timezone and see if it helps.

Thanks!

Martin
08-03-2016, 09:35 AM
It doesn't help.

It still crashes on Win7 and Win10 on virtual and real PC's.

And: It doesn't crash at launch but during the second snapshot stage.

Alpesh
08-04-2016, 04:15 PM
Hi,

If you have maintenance, please contact our Support and one of us can assist you with this.

Thanks!

Martin
08-08-2016, 06:39 AM
I tried to narrow down the number of files/regkeys to get a testcase and probably found what's causing the crash...

An (any?) addition to the path environment variable results in a crashing Repackager. So instead of the number
of files it's something else.

Alpesh
08-09-2016, 02:30 PM
Hi,

Can you reproduce this issue, if you create a sample installer which modifies the path variable? Please let me know.

Thanks!

Alpesh
08-09-2016, 03:34 PM
Hi,

Our Dev team was able to reproduce this issue. They are working to fix this issue. I will provide an update, once we have more information.

In the meantime, you can try using Single Step snapshot or Installation Monitoring methods as a workaround.

Hope this helps.

Thanks!

Martin
08-10-2016, 04:42 AM
Thanks.

We prefer to use the "multiple steps" method and we are looking forward to get the fix.

Alpesh
08-16-2016, 04:47 PM
Hi,

The Engineering team has provided us with a fix for this issue. Please note that this has not gone through a full QA cycle. Download the attached fix. Prior to copying the new xniSpy32.dll file, take the backup of the existing xniSpy32.dll under the 'C:\Program Files (x86)\AdminStudio\2016\Repackager' folder. After copying the new file to the same location, perform the same multi-snapshot test again.

Hope this helps.

Thanks!

Martin
08-18-2016, 06:01 AM
It works in most circumstances: An addition to the beginning or end of the PATH environment variable doesn't result in a crash anymore. However an "in between" addition results in a crash of the repackager. An older version of the repackager displays a warning message:
Changes to the PATH statement have been made that can't be detected by the Repackaging Wizard. You have to use the "AppendPath" command and modify the environment variable manually.

The older repackager continues after pressing the only available "OK" button in the dialog box. It doesn't crash.

Until now (doing this kind of work for several years) I can't remember I've ever seen this dialog box. So it's not an issue for us but it might be for other people.

Alpesh
08-22-2016, 11:17 AM
Thanks Martin for the feedback. Our Development team is working on your feedback to make the Repackager better.

Thanks!