PDA

View Full Version : Installshild compilation error



moonhochung
03-04-2016, 01:53 PM
We have InstallShild 2012 Spring SP1 version of ism file and I installed InstallShild 2015 Professional trial. After upgrading it, I am getting following error messages:

1>ISDEV : error -6003: An error occurred streaming 'C:\Program Files (x86)\InstallShield\2015\SetupPrerequisites\Microsoft .net\3.5\Full\dotnetfx35.exe' into setup.exe
1>ISDEV : fatal error -5087: Stop at first error

I don't even require .net 3.5. We only require .net 4.0 client profile.
How can I resolve this issue?

Thanks.
Moon

lwerenka
03-04-2016, 06:56 PM
You may have accidentally checked a prerequisite under the Application Data-> Redistributables tab and do not have it downloaded to your development PC. Go into Redistributables and find the .NET3.5 package that the error is referring to and uncheck it, if that is the case.

moonhochung
03-07-2016, 11:54 AM
Thank you for the reply, Iwerenka. But I checked before and I checked again today in Application Data->Redistributables, there is only one thing checked which is "Microsoft Office 2007 PIA".
I even opened the .ism file in notepad and searched for the string dotnetfx35 but I did not find one.
Any other suggestion?

lwerenka
03-07-2016, 06:55 PM
Two other options that I can think of:
1. Look under "Behavior and Logic ->Support Files/Billboards" and see if the .NET3.5 is one of the support files listed in any of the directories. Delete if there.
2. If you have scripts under "Behavior and Logic-InstallScript", see if there is any references to the .NET3.5 file.