PDA

View Full Version : java.lang.NullPointerException while uninstalling



pratapksp
02-26-2016, 03:27 AM
Hi

I am trying create a installer with Installanywhere 2013 which will install tomcat and deploy a java web application in it.
When i try to uninstall, i am getting a error saying java.lang.NullPointerException (after splash screen).
Attaching screen shorts.
Can some one help me.
1105711058

Thanks
Pratap

igiguere
02-29-2016, 04:47 PM
Hi;

I had a similar issue, it was a few missing images.
A NullPointerException while trying to use the uninstaller is possibly because of a missing resource or image. Did you modify the iap_xml file manually, in a text editor ? If so, you may have modified paths or names that are not visible in the IA designer UI, so you will not be aware of them. If you modify the iap_xml file manually, make sure all the paths and names of resources and images are correct.

I had a long thread with support about this. Flexera seems to have the "wishful thinking" approach to this kind of issue. They don't "support" modifying the iap_xml file manually...but then, they have to support people who get stuck because they don't catch this NPE. There are images and resources listed in the iap_xml file, but they just assume that this file can never be corrupted and will never be changed by anyone. If your IA designer is configured to fail on missing resources, this "fail fast" behavior does not apply to these "hidden" resources and images.

Anyways.

Hope it helps you or someone else.

pratapksp
03-02-2016, 04:18 AM
Hi igiguere,

Thanks for the response. It was very helpful.


Hi;

I had a similar issue, it was a few missing images.
A NullPointerException while trying to use the uninstaller is possibly because of a missing resource or image. Did you modify the iap_xml file manually, in a text editor ? If so, you may have modified paths or names that are not visible in the IA designer UI, so you will not be aware of them. If you modify the iap_xml file manually, make sure all the paths and names of resources and images are correct.

I had a long thread with support about this. Flexera seems to have the "wishful thinking" approach to this kind of issue. They don't "support" modifying the iap_xml file manually...but then, they have to support people who get stuck because they don't catch this NPE. There are images and resources listed in the iap_xml file, but they just assume that this file can never be corrupted and will never be changed by anyone. If your IA designer is configured to fail on missing resources, this "fail fast" behavior does not apply to these "hidden" resources and images.

Anyways.

Hope it helps you or someone else.