PDA

View Full Version : -1001 Error opening MSI database



isaacF
12-17-2015, 10:54 AM
I'm running InstallShield 2015 Professional and have an install project that was working fine last week. In fact, the last thing I did Friday before I left work was build the installer. When I came in Monday morning, the project would not finish building to a Single EXE Image and is throwing a -1001 Error opening MSI database message.

The Project is a basic MSI project with nothing crazy going on, but as it gets to the final stages of the build, it creates a application, the .msi database, and an .ini file.

The Flexera Knowledge Base points me to reinstalling Windows Installer, which I have done and manually registered all the applicable .dll's.

Has anyone else encountered this issue and found a fix action? The craziest thing is this build worked last week, then just quit. I am at a total loss.

Thanks.

DLee65
12-17-2015, 11:16 AM
Have you restarted the machine?
My guess is that it is having difficulties cleaning up from the last build, but that is only a guess based on your description.

Try manually deleting the build folder and see if that helps.

isaacF
12-17-2015, 12:12 PM
I've restarted the machine, I've uninstalled and reinstalled InstallShield, I've reverted back to a previous snapshot of the machine trying to get it back to a state before I started getting the error, and I've completely rebuilt the project from scratch.

Is there anything more I can do to clean up from the previous build?

DLee65
12-18-2015, 01:44 PM
Is there any chance that it sends some information to the event viewer.
I still say that it is having a tough time trying to create the output folder and\or file. Is there enough disk space, folder permissions, etc.

I would have thought that reverting your machine would have solved the issue for you too.

Good luck on this - things like this can be aggravating.