PDA

View Full Version : Another instance of this setup is already running - problem with suite.



pmeklin
10-13-2015, 06:49 AM
Error message: "Another instance of this setup is already running. Please wait for the other instance to finish and then try again."
- is always shown when trying to Modify, Repair or Remove suite project where Cache Packages Locally- setting is set as No in Releases/Setup.exe- view.
No errors if this setting is set to Yes.

Is there any solutions for this?

pmeklin
10-29-2015, 07:21 AM
Am i missing something or is this a bug in Suite when primary package is InstallScript MSI Project?

This behaviour is very easy to reproduce:
Create an InstallScript MSI setup package (with any contents) and build it.
Create a new Suite project, add one feature and add a New executable package (.exe). (Use your just created setup - of course)
Create a detection condition for a package.
Build suite and install it.
After installation, run suite again to enter maintenance mode and select e.g. Repair. No errors, setup starts normally with Maintenance mode and setup can be Modified, Repaired or Removed normally. (No silent modes used in this example.)

BUT, if you select from Releases view: Setup.exe tab/Cache Packages Locally = No, (Default is Yes)
Build suite again and install it (be sure to uninstall previous version first)
Then run suite again to enter maintenance mode - when selecting e.g. Repair - suite dialog starts by saying: Repairing package xxxx and an InstallShield Wizard error message box appears saying: "Another instance of this setup is already running. Please wait...."

Any help is appreciated

-P-