PDA

View Full Version : Can't find dependency for reportviewer2012



isalsa
09-24-2015, 12:15 AM
What I use is VS2015pro plus Installshield2015 LE. I think that's the latest version. I try to make install package for a VB.net project with reportviewer2012. While building, it appears the following errors.

-6003: An error occurred streaming 'C:\Program Files\InstallShield\2015LE\SetupPrerequisites\Microsoft SQL Server 2012 Express SP1 System CLR Types (x86).prq' into setup.exe ISEXP : error : -6003: An error occurred streaming 'C:\Program Files\InstallShield\2015LE\SetupPrerequisites\Microsoft SQL Server 2012 Express SP1 System CLR Types (x86).prq' into setup.exe

-7066: Your project contains a reference to the InstallShield prerequisite C:\Program Files\InstallShield\2015LE\SetupPrerequisites\Microsoft SQL Server 2012 Express SP1 System CLR Types (x86).prq; however, this file cannot be located. Either remove the InstallShield prerequisite from your project, or locate this file. ISEXP : error : -7066: Your project contains a reference to the InstallShield prerequisite C:\Program Files\InstallShield\2015LE\SetupPrerequisites\Microsoft SQL Server 2012 Express SP1 System CLR Types (x86).prq; however, this file cannot be located. Either remove the InstallShield prerequisite from your project, or locate this file.

I check the content of Microsoft ReportViewer 2012.prq, and find it has a dependency of Microsoft SQL Server 2012 Express SP1 System CLR Types (x86).prq . But in the installed folder of Installshield, there's only Microsoft SQL Server 2012 Express SP2 System CLR Types (x86).prq. I try to modify the prg file of reportviewer, and change the dependency form SP1 to SP2. It can be built. But after installation, the program can not work propertly.

Where can I find Microsoft SQL Server 2012 Express SP1 System CLR Types (x86).prq ? Or can give me a solution to make install for reportviewer2012 ?

MichaelU
09-24-2015, 10:22 AM
Have you updated to SP1? It contains an updated ReportViewer prerequisite file that addresses this.

isalsa
09-25-2015, 12:43 AM
Have you updated to SP1? It contains an updated ReportViewer prerequisite file that addresses this.

What I use is InstallShield 2015 Limited Edition for Visual Studio. Does this version have the SP1? I searched over flexerasoftware.com, but didn't find any SP1 for this.

MichaelU
09-25-2015, 08:44 AM
Ah, then you should be posting in the "InstallShield Limited Edition for Visual Studio" forum instead. While there isn't an SP1 for the limited edition at this point, the prq file in question can be shared from the other editions of the product.

Sergiy Vakshul
03-19-2016, 04:38 PM
Where can I find Microsoft SQL Server 2012 Express SP1 System CLR Types (x86).prq ? Or can give me a solution to make install for reportviewer2012 ?

I have the same problem.
Tell me, please, how you fixed it?

therealbogeyman
05-05-2016, 01:20 PM
You can find the downloadable Microsoft files here: https://www.microsoft.com/en-us/download/details.aspx?id=43339. You can use the pre-requisites editor or simply edit an existing pre-req file with a text editor (it's just XML form text).

DanLeduc
10-31-2016, 08:32 PM
I think that I found the Microsoft SQL Server 2012 Express SP1 System CLR Types (x86) and I even tried editing the prq file to point to what I found.. I can get the install project to compile, but I obviously still have something wrong since the install does not work. It was mentioned that one could use the prq file from another edition of Installshield. Is it possible for someone to post it so that I get it right?