PDA

View Full Version : Remote Repackager install unable to locate specific VCRedist it requires



msitekkie
08-26-2015, 11:18 AM
When I run the Setup.exe for Remote Repackager in AdminStudio 2015 it fails looking for a dependency - Visual C++ 2012 Update 1 Redist.

This version is not available for download from Microsoft (which offers you Update 4) and Repackager still fails with the same message if Update 4 is installed.

Looking at the files extracted by setup.exe under the %TEMP% folder I notice that Setup.INI has:

[ISSetupPrerequisites]
PreReq0=Microsoft Visual C++ 2012 Update 1 Redistributable Package (x86).prq
PreReqFeatures0=Main

I located a copy of this .prq file in C:\Program Files (x86)\AdminStudio\2015\Repackager\SetupPrerequisites
but continued to get the same error after copying this into the same folder as the .INI file & .MSI. I also tried placing it in the same folder as setup.exe.

Can anybody tell me how to resolve this issue so I can install Remote Repackager on my VM

SherylSikora
08-26-2015, 12:40 PM
The correct installer for VC 2012 Update 1 can be downloaded from the following location: Microsoft Visual C++ 2012 Update 1 (http://download.microsoft.com/download/1/6/b/16b06f60-3b20-4ff2-b699-5e9b7962f9ae/VSU1/vcredist_x86.exe). Install that on your machine and then run the installer for the Remote Repackager again.