PDA

View Full Version : Signed installer on OS X starts again and again



AWallner
06-25-2015, 02:55 AM
Hi,

I built an signed installer on Windows 7 with the options Platforms/Mac OS X/Requires Administrator Name and Password and Code sign the installer turned on for MAC OS X.
On the Mac I manually sign the helper tool, the installer/uninstaller and the wrapper. A check with codesign -vvv name.app was successfully.

If the installer is opened, I have to enter the password to install the helper tool as expected. After that the GUI of the installer is shown.

If I now abort the installer or go through the steps until it is finished, the helper tool opens the installer again and again.

I have lots of entries like this in the log:

com.apple.xpc.launchd[1]: (com.flexera.ia.launcher) Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

com.apple.xpc.launchd[1]: (com.flexera.ia.launcher[13408]) Service exited with abnormal code: 1


When the installer is unsigned it works, because the helper tool is not installed. The platform is OS X 10.10.4 Yosemite.


Regards,

Andy


It seems like it tries to start the uninstaller, but instead the installer is started again.

weelyn
10-06-2015, 04:36 AM
I have the exact same problem. It's driving me mad, I assume the installer is launched repetitively by launchd, but can't seem to find anything ins /Library/Launch* to support this. If I find something I'll say it here.

PS: rebooting sloves the issue, so it's either a transient config that get trashed when rebooting, or some other background program that repetitively launches the setup...